Search:
Submit Search


Hauptwerk set up help with Nord C2D/x keys

A discussion forum for anything even marginally Hauptwerk-related.

Re: Hauptwerk set up help with Nord C2D/x keys

Postby BLF » Thu Jun 28, 2018 7:54 pm

Awesome info guys and Iain was right on the mark. For some reason they were all sending #1 ?? All is good now that they are back to default. You guys are invaluable :)

Still having the x-keys behave the same way as described above. They are sending Unicode so I don't get how it would double up?

He's playing the hell out of it so it's nice to get it 90% there!
BLF
Member
 
Posts: 14
Joined: Mon Jun 25, 2018 5:43 pm

Re: Hauptwerk set up help with Nord C2D/x keys

Postby BLF » Fri Jun 29, 2018 8:40 am

X-Keys are the last thing and hopefully this makes sense to someone - I'm going to try to reprogram the x keys again and calling x-keys themselves, but I ran a MIDI diagnostic file for Martin, just pressing two of the x keys, 15 seconds apart. I had them assigned to two different letters, z & x, and evidenced by using the x-keys in notepad, you see both each letter come up correctly when pressing each key. But both are sending the same letter to Hauptwerk though? z ?

Thanks, Brian.

I can see from your diagnostic file that both keys are actually sending the same key code to the computer:


2018-06-29-07-19-54: INF:2557 Diag: IN: computer key pressed: hex key code: 0000005A.
2018-06-29-07-20-10: INF:2557 Diag: IN: computer key pressed: hex key code: 0000005A.

Key code 5A is the letter 'Z'.

That must be due to the way they're configured in the X-Keys software, but I can't help with that, I'm afraid. Hopefully an X-Keys user on the forum will be able to help you (or perhaps you could contact the makers of the X-Keys unit for support if needed).
BLF
Member
 
Posts: 14
Joined: Mon Jun 25, 2018 5:43 pm

Re: Hauptwerk set up help with Nord C2D/x keys

Postby BLF » Fri Jun 29, 2018 10:18 am

ALL DONE :)

Talked to x-keys and they said to try sending a "Keystroke" instead of "Text" when programming them and it's now good to go. I just had to manually reprog the 36 x keys.

I hope this thread can help someone in the future if they are using the same setup.

Thanks to the killer forum and Martin/Brett for great product support. We will be Hauptwerk users for life - great stuff.
BLF
Member
 
Posts: 14
Joined: Mon Jun 25, 2018 5:43 pm

Previous

Return to General discussion

Who is online

Users browsing this forum: No registered users and 1 guest