Search:
Submit Search


OS X 10.10 'Yosemite' compatibility with Hauptwerk v4.1.1

Latest updates to Hauptwerk.

OS X 10.10 'Yosemite' compatibility with Hauptwerk v4.1.1

Postby B. Milan » Thu Oct 16, 2014 3:36 pm

Image

Apple is releasing OS X 10.10 'Yosemite' today, which we've been testing for compatibility with the current version of Hauptwerk (v4.1.1).

Except for some audio/MIDI interface drivers not yet being compatible (which presumably their makers will address soon), the only issues that we found were:

- Hauptwerk v4.1.1's installer requires Apple's Java for OS X (Java 1.6). OS X 10.8 and 10.9 offered the option to install that component automatically if needed when launching an application that required it. OS X 10.10 still offers the option to download it, but it no longer installs it automatically, so if you don't already have that Java for OS X component installed then you need to follow the OS X prompt to download it, then to launch the downloaded Java installer to install it, then to launch the Hauptwerk installer again once Java has been installed.

- There are some very minor cosmetic issues with the appearance/layout of various screens, including some misaligned text on push-buttons, misaligned text on group boxes, misaligned right-click menu text and keyboard input focus not being shown correctly for check-boxes, radio buttons and buttons. However, none of these have any impact on using Hauptwerk (unless possibly you navigate between settings using the TAB key, in which case not being able to identify which setting has the input focus might be a minor hindrance).

- OS X 10.10 isn't shown as the operating system version in the Hauptwerk log.

We found no functional or performance issues with Hauptwerk itself; everything appears to work properly and perform as well as on previous OS X versions.

In order for us to resolve the minor cosmetic appearance/layout issues we need to wait for an updated version of a third-party component (the Qt multi-platform library) that Hauptwerk relies upon. Therefore we plan to release an updated version of Hauptwerk (v4.1.2) to address those issues shortly after the necessary updated component is available to us.

However, in the meantime we will support Hauptwerk v4.1.1 with OS X 10.10, in addition to 10.7, 10.8 and 10.9, subject to the minor known issues listed above. If you have a license for Hauptwerk, please ensure that you have the latest version of the driver for the Hauptwerk USB key installed, which can be found on our main downloads page here: http://www.downloadhauptwerk.com/

[As with all operating system version upgrades, our general recommendation for maximum platform reliability would always be to perform a clean installation of the new operating system (re-format the disk partition), rather than upgrading a previous operating system partition or migrating any settings from previous operating system installations, to ensure that no file/folder permission migration issues, or operating system setting/component/driver migration issues can arise. Hauptwerk's backup/restore mechanisms can safely be used to migrate Hauptwerk settings from a previous installation to a new one.]
Regards,
Brett Milan
http://www.hauptwerk.com
http://www.milandigitalaudio.com
Send Email

Image

_________________________________
Please use email for contacting us. No private messages please.
User avatar
B. Milan
Site Admin
 
Posts: 4313
Joined: Sat Aug 30, 2003 11:15 am
Location: Tampa, FL. USA

Re: OS X 10.10 'Yosemite' compatibility with Hauptwerk v4.1.

Postby mdyde » Tue Dec 09, 2014 12:53 pm

A new version of the Hauptwerk USB key driver (v6.65) for OS X is now available from its manufacturers, which they list as officially adding OS X 10.10 support. It can be now downloaded via our main downloads page:

http://www.downloadhauptwerk.com/

(Although the previous version did work properly with Hauptwerk v4.1.1 on OS X 10.10, spurious error messages would appear in the OS X system log. This new version resolves those.)

Please note that the new version still isn't signed, though, so, once downloaded, you still need to right-click on its installer and select 'Open' to launch it, rather than simply double-clicking on it.
Best regards,
Martin.

[Please use email or the Contact page if you need to contact us privately, rather than private forum messages.]

Image
User avatar
mdyde
Moderator
 
Posts: 10347
Joined: Fri Mar 14, 2003 2:19 pm
Location: UK


Return to News, announcements and forum rules

Who is online

Users browsing this forum: No registered users and 1 guest