Search:
Submit Search


Using extended samples. . . how to?

Using the CODM to create your own organ definitions, exchange CODM organ definitions, ...

Using extended samples. . . how to?

Postby CHRIS 037 » Tue Mar 16, 2010 3:37 pm

Hi Martin and Brett (plus other CODM’ers),

My CODM organ is coming along just fine. . . except for:

I have been trying to load the Solo String and its Celeste into my CODM. These ranks are from the MasterWorks 3/31.

I can get the two ranks to load OK. But since the samples go from midi 24 to 108, I hoped to be able to use my 16’ and 4’ couplers to extend the 8’ pitch down and up. The 4’ part does work. The 16’ also works except for the bottom octave. The 16’ pipes don’t go through the bottom octave, though there are samples that can go lower.

Following the instructions in the pdf user guide, I have set what I think are the relevant numbers as follows:

In Ranks:
NumberOfPipes = 85
MIDINoteNumberOfFirstPipe = 24
Samples_SampleMIDINoteNumOfFirstAvailableSample = 24
Samples_SampleMIDINoteNumOfLastAvailableSample = 108
Pitch_RankBaseOutputPitch64ftHarmonicNum = 8

In StopRank:
MIDINoteNumOfFirstMappedDivisionKey = 36
NumberOfMappedDivisionKeys = 73 (I have set up extended keyboards with 73 keys to better deal with pianos)

But, when I load this into HW I get the message:
"Enclosure ID 000240 has pipe ID 042008 listed as an invalid element – neither of the maximum frequencies can be equal to the frequency of its corresponding minimum.
Message Code 3151."

(The division (keyboard) is #5, hence the ID of 000240.)

I must confess that I don’t understand this error message.

Thanks for your help,

Leo Chris.
User avatar
CHRIS 037
Member
 
Posts: 1006
Joined: Tue Dec 30, 2003 10:01 pm
Location: Spokane, WA, USA

Re: Using extended samples. . . how to?

Postby B. Milan » Tue Mar 16, 2010 6:30 pm

Hello Leo,

In order to allow a Sub Coupler to extend below the normal manual compass you need to change the following:

MIDINoteNumOfFirstMappedDivisionKey = 36

to

MIDINoteNumOfFirstMappedDivisionKey = 24

The enclosure error just means that your frequency settings are incorrect and that one cannot be higher than the other according to where you placed them in the open/closed states.

Have a look at the example St. Anne's CODM files and you can try using those filter settings as a basis to go by.

I hope that helps.
Regards,
Brett Milan
http://www.hauptwerk.com
http://www.milandigitalaudio.com
Send Email

Image

_________________________________
Please use email for contacting us. No private messages please.
User avatar
B. Milan
Site Admin
 
Posts: 4358
Joined: Sat Aug 30, 2003 11:15 am
Location: Tampa, FL. USA

Re: Using extended samples. . . how to?

Postby CHRIS 037 » Tue Mar 16, 2010 7:43 pm

I have found one difference that may be a very BIG problem(?)

(Changing the 36 to a 24 still leads to the enclosure error.) However. . .

In comparing my CODM with the St.Anne's examples there are a few different entries in the encolsure section. That led me to discover that I am using a CODM I started last year that shows a file format version of 3.00. The later St.Anne's shows version 3.20.

Evidently some changes have been made since I last started a new CODM.

I notice that the enclosure numbers are somewhat different. Plus, there are a couple entries that are new. I have been using the numbers from the older St.Anne's, BTW.

So, the big question is, if this is the problem, is there any way to transfer a large older CODM into the newer format? Or, perhaps just copy in needed lines for this one problem (since everything has worked as expected otherwise)?

Leo Chris.
User avatar
CHRIS 037
Member
 
Posts: 1006
Joined: Tue Dec 30, 2003 10:01 pm
Location: Spokane, WA, USA

Re: Using extended samples. . . how to?

Postby B. Milan » Tue Mar 16, 2010 8:56 pm

Hello Leo,

The enclosure error doesn't relate the the MIDI note division numbers at all, these are two separate and unrelated items. Your enclosure error has to do with incorrect frequency values that you've entered. That is why I said to have a look at the example files which have correct formatting.

See the error meaage which states:

Enclosure ID 000240 has pipe ID 042008 listed as an invalid element – neither of the maximum frequencies can be equal to the frequency of its corresponding minimum.

I don't know what values you've entered, but try adjusting these and that should fix that error. Here's an example that does work from the example 6 CODM file:

<Encl_FiltParamWhenClsdForPipeMIDINoteNum036_OverallAttnDb>7.268894387101</Encl_FiltParamWhenClsdForPipeMIDINoteNum036_OverallAttnDb>
<Encl_FiltParamWhenClsdForPipeMIDINoteNum036_MaxFreqHz>62.41471899004</Encl_FiltParamWhenClsdForPipeMIDINoteNum036_MaxFreqHz>
<Encl_FiltParamWhenClsdForPipeMIDINoteNum036_MinFreqHz>249.6588759602</Encl_FiltParamWhenClsdForPipeMIDINoteNum036_MinFreqHz>
<Encl_FiltParamWhenClsdForPipeMIDINoteNum036_ExtraAttnAtMinDb>7.778569843833</Encl_FiltParamWhenClsdForPipeMIDINoteNum036_ExtraAttnAtMinDb>
<Encl_FiltParamWhenOpenForPipeMIDINoteNum036_MaxFreqHz>118.7626905951</Encl_FiltParamWhenOpenForPipeMIDINoteNum036_MaxFreqHz>
<Encl_FiltParamWhenOpenForPipeMIDINoteNum036_MinFreqHz>475.0507623805</Encl_FiltParamWhenOpenForPipeMIDINoteNum036_MinFreqHz>
<Encl_FiltParamWhenClsdForPipeMIDINoteNum096_OverallAttnDb>3.95737214592</Encl_FiltParamWhenClsdForPipeMIDINoteNum096_OverallAttnDb>
<Encl_FiltParamWhenClsdForPipeMIDINoteNum096_MaxFreqHz>2123.727986097</Encl_FiltParamWhenClsdForPipeMIDINoteNum096_MaxFreqHz>
<Encl_FiltParamWhenClsdForPipeMIDINoteNum096_MinFreqHz>4247.455972194</Encl_FiltParamWhenClsdForPipeMIDINoteNum096_MinFreqHz>
<Encl_FiltParamWhenClsdForPipeMIDINoteNum096_ExtraAttnAtMinDb>14.16275620904</Encl_FiltParamWhenClsdForPipeMIDINoteNum096_ExtraAttnAtMinDb>
<Encl_FiltParamWhenOpenForPipeMIDINoteNum096_MaxFreqHz>4081.040047892</Encl_FiltParamWhenOpenForPipeMIDINoteNum096_MaxFreqHz>
<Encl_FiltParamWhenOpenForPipeMIDINoteNum096_MinFreqHz>8162.080095785</Encl_FiltParamWhenOpenForPipeMIDINoteNum096_MinFreqHz>



In order to make use of the newer CODM format you should just be able to copy any new settings from the newer examples into your existing files, be sure to retain all of the headings (opening and closing bracket items), then those new settings should work.
Regards,
Brett Milan
http://www.hauptwerk.com
http://www.milandigitalaudio.com
Send Email

Image

_________________________________
Please use email for contacting us. No private messages please.
User avatar
B. Milan
Site Admin
 
Posts: 4358
Joined: Sat Aug 30, 2003 11:15 am
Location: Tampa, FL. USA

Re: Using extended samples. . . how to?

Postby CHRIS 037 » Tue Mar 16, 2010 10:21 pm

Nope! Still no luck.

I carefully copied those lines into the CODM and still get the same error. The only way I can get the instrument to load is when I set MidiNoteNumberOf FirstPipe = 36. Other settings are as above, with the change
MIDINoteNumOfFirstMappedDivisionKey = 24
that you suggested.

When loaded thus, the expression works fine (but, it also still works fine with the settings I originally had which were copied from the St. Anne's CODM also). But, I don't get the bottom octave of 16' pitches.

And, as soon as I change the 36 to 24, the error occurs again. It does seem there is some sort of connection there(?).

Leo Chris.
User avatar
CHRIS 037
Member
 
Posts: 1006
Joined: Tue Dec 30, 2003 10:01 pm
Location: Spokane, WA, USA

Re: Using extended samples. . . how to?

Postby mdyde » Wed Mar 17, 2010 6:41 am

Hello Leo,

It might be quickest if you just send us your CODM file and then we can load it here, check it, and let you know exactly where the problem is.

In comparing my CODM with the St.Anne's examples there are a few different entries in the encolsure section. That led me to discover that I am using a CODM I started last year that shows a file format version of 3.00. The later St.Anne's shows version 3.20.

Evidently some changes have been made since I last started a new CODM.


Hauptwerk is fully backwardly-compatible with all previous CODM file formats, so no changes are needed on your part for that.
Best regards,
Martin.

[Please use email or the Contact page if you need to contact us privately, rather than private forum messages.]

Image
User avatar
mdyde
Moderator
 
Posts: 10644
Joined: Fri Mar 14, 2003 2:19 pm
Location: UK

Re: Using extended samples. . . how to?

Postby mdyde » Wed Mar 17, 2010 10:07 am

Hello again, Leo.

P.S.

The Rank.Encl_... parameters are always specified for note numbers 36 and 96, and then projected linearly for all other note values in the rank.

For any given note the maximum and minimum frequencies with the box open aren't allow to be equal (because that would give a frequency response with an infinitely-steep transition). Likewise for the maximum and minimum frequencies with the box closed.

Hence I think your current swell box parameters don't violate that rule settings when projected between note numbers 36 and 96, but do violate it when projected (linearly) beyond those notes.

To help explain: imagine a graph with evenly-spaced MIDI note numbers along the x-axis and frequency in kHz on the y-axis.

Plot the Rank.Encl_FiltParamWhenClsdForPipeMIDINoteNum036_MaxFreqHz and Rank.Encl_FiltParamWhenClsdForPipeMIDINoteNum096_MaxFreqHz points on the graph then draw a line through them, extended as far as the lowest and highest actual notes in your rank (e.g. to note numbers 24 and 108 for an 8-octave unified theatre organ rank).

Now do the same thing for Rank.Encl_FiltParamWhenClsdForPipeMIDINoteNum036_MinFreqHz and Rank.Encl_FiltParamWhenClsdForPipeMIDINoteNum096_MinFreqHz.

The two lines are not allowed to cross (because it would need a filter with an impossible frequency response).

On a separate sheet of graph paper do the same thing for Encl_FiltParamWhenOpenForPipeMIDINoteNum036_MaxFreqHz and Encl_FiltParamWhenOpenForPipeMIDINoteNum096_MaxFreqHz (join those two with a line of the appropriate length) and then again for Encl_FiltParamWhenOpenForPipeMIDINoteNum036_MinFreqHz and Encl_FiltParamWhenOpenForPipeMIDINoteNum096_MinFreqHz.

Likewise, those two lines are not allowed to cross.

The error you're getting means that one of those two graphs has crossing lines (and thus specifies a filter with an impossible frequency response).
Best regards,
Martin.

[Please use email or the Contact page if you need to contact us privately, rather than private forum messages.]

Image
User avatar
mdyde
Moderator
 
Posts: 10644
Joined: Fri Mar 14, 2003 2:19 pm
Location: UK

Re: Using extended samples. . . how to?

Postby CHRIS 037 » Wed Mar 17, 2010 11:00 am

I'll have a look at the graph idea in a bit.

Thanks very much for this information. It takes the problem out of the murky area of the unknown and gives me a chance to attack it. After breakfast I'll do some graphing as see if I can figure this out. I'll let you know how this works out in an hour or so

As to sending you the CODM. . . I'll do that later if necessary. however, it needs a screen that is 1600 x 1200 to load properly. I generally have all but the few ranks I'm working on "active" so I can load such a large instrument in a much shorter time (so you won't need all the different organs I'm including). I will shut down all but the ranks in question (from the Milan 3/31 TO). But the display might spread beyond the usual resolution these days.

Thanks, for the detailed info, :)

Leo Chris.
User avatar
CHRIS 037
Member
 
Posts: 1006
Joined: Tue Dec 30, 2003 10:01 pm
Location: Spokane, WA, USA

Re: Using extended samples. . . how to?

Postby CHRIS 037 » Wed Mar 17, 2010 1:39 pm

So, after making some graphs, it appears that the lines crossed at about midi note 30.

I adjusted the slope a bit of the two minimum open/closed at note 36. That looks to make a crossing somewhere below midi 24. The CODM now does load without the enclosure error and with the "midi note number of first pipe" = 24.

However, those notes in the bottom octave using the 16' coupler on the 8' string still do not sound.

Is there another suggestion I can try? I can certainly live with things as they are. A suboctave coupler on a manual is of minimal use to me in that bottom octave, but I thought that the thinner string sound might work out well with it.

Leo Chris.
User avatar
CHRIS 037
Member
 
Posts: 1006
Joined: Tue Dec 30, 2003 10:01 pm
Location: Spokane, WA, USA

Re: Using extended samples. . . how to?

Postby mdyde » Wed Mar 17, 2010 1:59 pm

Hello Leo,

However, those notes in the bottom octave using the 16' coupler on the 8' string still do not sound.


Assuming you want an 8-octave unified rank (one octave extension at the bottom, and another at the top), for the relevant objects, you should just need to make sure you have the following parameters set correctly:

Division.NumberOfKeyActionNodesIfDifferentFromNumberOfKeys = 85
Division.MIDINoteNumOfFirstKeyActionNodeIfDifferentFromFirstKey= 24

Rank.NumberOfPipes = 85
Rank.MIDINoteNumberOfFirstPipe = 24

StopRank.MIDINoteNumOfFirstMappedDivisionKey = 24 (assuming this stop sounds at the ranks unison pitch)
StopRank.NumberOfMappedDivisionKeys = 85 (assuming this stop sounds at the ranks unison pitch)
Best regards,
Martin.

[Please use email or the Contact page if you need to contact us privately, rather than private forum messages.]

Image
User avatar
mdyde
Moderator
 
Posts: 10644
Joined: Fri Mar 14, 2003 2:19 pm
Location: UK

Re: Using extended samples. . . how to?

Postby CHRIS 037 » Wed Mar 17, 2010 2:29 pm

Yes! Excellent!! :D

The notes now play as I wished.

I had not added the numbers in the Division section. . . missed that completely.

Thanks so much! I can again move ahead. . . feels so good when things work so well !

Thanks!!!!!

Leo Chris.
User avatar
CHRIS 037
Member
 
Posts: 1006
Joined: Tue Dec 30, 2003 10:01 pm
Location: Spokane, WA, USA

Re: Using extended samples. . . how to?

Postby mdyde » Wed Mar 17, 2010 2:55 pm

Thanks, Leo.

You're welcome.
Best regards,
Martin.

[Please use email or the Contact page if you need to contact us privately, rather than private forum messages.]

Image
User avatar
mdyde
Moderator
 
Posts: 10644
Joined: Fri Mar 14, 2003 2:19 pm
Location: UK


Return to Custom Organ Design Module (CODM)

Who is online

Users browsing this forum: No registered users and 1 guest