Search:
Submit Search


Another problem: Manual 3 to Manual 2 coupler

Using the CODM to create your own organ definitions, exchange CODM organ definitions, ...

Another problem: Manual 3 to Manual 2 coupler

Postby ldeutsch » Wed Dec 15, 2010 7:47 pm

Martin,

I think you are the only one who can help me with this one. I discovered that the coupler code for Manual 3 to Manual 2 8ft, which is listed n the CODM documentation as 1216, actually implements Manual 1 to Manual 3 8ft - just the same as 1306. I have tried it several times. I am using the 1216 coupler in my 945 organ but I had not actually tried it until today. I intend to release a new version with the sampling rate corrected but I want to have this working too.

Les
User avatar
ldeutsch
Member
 
Posts: 449
Joined: Tue Mar 04, 2008 1:02 pm
Location: Chatsworth, California, USA

Re: Another problem: Manual 3 to Manual 2 coupler

Postby mdyde » Thu Dec 16, 2010 9:06 am

Hello Les,

Are you certain about that?

I don't have Hauptwerk v3 installed at the moment, but I've just tried it in Hauptwerk v4 and it seems to work fine for me using the ExampleCustomOrgan2 organ. I also had a brief look through the source code for both Hauptwerk v4 and v3 and I couldn't spot any relevant differences - they both look correct.

The ExampleCustomOrgan2 example organ includes coupler 1216 (Choir to Swell 8 - the second drawknob from the bottom of the far left column on the screen).

Does that coupler in that example organ work properly for you? E.g. if you draw the Geigen Principal 8 on the Swell, the Clarinet 8 on the Choir and then click on keys on on the topmost displayed manual (the Swell), then draw the Swell to Choir coupler (second drawknob from the bottom of the far left column on the screen) then the Clarinet should start to play.

Maybe you have your Division.DivisionCodes switched around somewhere? (I haven't had a chance to go through your organ definition.)
Best regards,
Martin.

[Please use email or the Contact page if you need to contact us privately, rather than private forum messages.]

Image
User avatar
mdyde
Moderator
 
Posts: 10644
Joined: Fri Mar 14, 2003 2:19 pm
Location: UK

Re: Another problem: Manual 3 to Manual 2 coupler

Postby ldeutsch » Thu Dec 16, 2010 12:07 pm

Martin,

I loaded ExampleCustomOrgan2 and it worked perfectly. I then compared the CODM text for coupler 1216 between this file and my own and found nothing different, save from the labels and the fact that I am not using sound effects for the drawknob action. I was puzzled.

I then reloaded my own organ and discovered that the coupler is working fine! I have no idea why it wasn't working last night. Perhaps I have a configuration management problem of my own or maybe it is an issue with my studio computer or its MIDI configuration. (I am using my work computer at the moment for this test.) In any event, the coupler is working. I'll check on any differences with my studio machine and let you know if I find anything strange.

Thanks again.

Les
User avatar
ldeutsch
Member
 
Posts: 449
Joined: Tue Mar 04, 2008 1:02 pm
Location: Chatsworth, California, USA

Re: Another problem: Manual 3 to Manual 2 coupler

Postby mdyde » Thu Dec 16, 2010 12:08 pm

Thanks, Les.

No problem.
Best regards,
Martin.

[Please use email or the Contact page if you need to contact us privately, rather than private forum messages.]

Image
User avatar
mdyde
Moderator
 
Posts: 10644
Joined: Fri Mar 14, 2003 2:19 pm
Location: UK


Return to Custom Organ Design Module (CODM)

Who is online

Users browsing this forum: No registered users and 2 guests