It is currently Thu Jan 21, 2021 12:51 pm


Expression pedal problems!

Building organ consoles for use with Hauptwerk, adding MIDI to existing consoles, obtaining parts, ...
  • Author
  • Message
Offline

JumboFitz6

Member

  • Posts: 3
  • Joined: Tue Jul 07, 2020 8:01 pm

Expression pedal problems!

PostFri Jul 24, 2020 4:59 am

Hi everyone,

I bought a second hand 3-pin expression pedal for my DIY organ that was originally from a different organ (don't know the make/model etc).

I am using a VPO board that is powering all my pistons and another expression pedal. The board works well.

When I connect the new pedal to the circuit board, the new pedal works with HW, the LED on the pedal comes on etc, but it stops everything else (pistons and other expression pedal) from working! When I disconnect the pedal, everything works again.

I have even tried connecting the pedal to the pins that the other expression pedal (that works with no problems) is attached to, and the same thing happens, so I know it is not an issue with the circuit board.

Anybody got any ideas of why this might be happening and how to make it work?

Thanks a million in advance :)
Offline

jkinkennon

Member

  • Posts: 1125
  • Joined: Thu May 07, 2009 9:43 am
  • Location: Vancouver, WA

Re: Expression pedal problems!

PostFri Jul 24, 2020 8:47 am

It is possible that the new expression pedal is not wired correctly and is shorting out the encoder's power while it is connected. It's also possible that you have an expression pedal that uses an optical device (the LED?) rather than a potentiometer which would be incompatible with most encoders.

Check the expression pedal with a multimeter to verify it is actually a potentiometer and that you have correctly identified the ends of the potentiometer and the wiper.
Offline
User avatar

engrssc

Member

  • Posts: 6825
  • Joined: Mon Aug 22, 2005 10:12 pm
  • Location: Roscoe, IL, USA

Re: Expression pedal problems!

PostFri Jul 24, 2020 3:02 pm

The potentiometer should measure between 5K and 10K ohms.
10K is preferable for most encoders.

Rgds,
Ex
Offline

JumboFitz6

Member

  • Posts: 3
  • Joined: Tue Jul 07, 2020 8:01 pm

Re: Expression pedal problems!

PostMon Jul 27, 2020 3:06 pm

Thanks a million!

I have taken the pedal apart and you were right. It is an LDR based pedal. I have ordered a potentiameter from Ebay and will use it with the pedal instead. Great call Jkinkennon :)

Return to DIY organ consoles / MIDI

Who is online

Users browsing this forum: No registered users and 1 guest