Search:
Submit Search


Expression pedals don't work

Please note: we can't provide official support for the Free Edition, but other users might be able to help you here.

Expression pedals don't work

Postby Lynnr » Thu Feb 09, 2017 12:07 pm

A friend just set up the free version of Hauptwerk with a Rodgers 505C as an interface and a Mac Laptop running OS 10.10.3,( using the newest free version of Hauptwerk I downloaded this week (Feb, 2017). The manuals and pedalboard work well, but the expression pedals do not work at all. Did we miss something in the setup? Any suggestions?
Lynnr
Member
 
Posts: 6
Joined: Sun Feb 21, 2016 5:45 pm

Re: Expression pedals don't work

Postby Grant_Youngman » Thu Feb 09, 2017 12:29 pm

I assume you tried to detect the expression pedals. Do you know what the Rodgers is sending when you move the pedals?

If not, Midi Monitor is a free app on the App store that you can install. It will tell you what is being seen (if anything) by the Mac.
Grant
User avatar
Grant_Youngman
Member
 
Posts: 923
Joined: Sat Jan 20, 2007 7:50 pm
Location: Savannah, Ga

Re: Expression pedals don't work

Postby Lynnr » Fri Feb 10, 2017 1:17 pm

Thanks so much for your help. I did figure out how to auto detect the swell pedal. I also tried it with the great-pedals pedal. The results however seem strange. The swell pedal I would expect to control volume like opening and closing the louvers on the swell box. What happens is that it increases volume by adding stops like a crescendo pedal. The swell pedal also does the same thing for the Great at the same time as it does for the Swell. I tried the auto detect on the Great-Pedals pedal and it does seem to detect it, but moving that pedal does nothing to the sound. However, I can see that pedal move on the on-screen console. I should have said that I have tried all this on the St. Anne's Moseley sample. I did also try this on a smaller organ sample with the same effect - it only adds stops. Am I expecting the wrong thing or have I done or not done something correctly? Thanks again to you and to to everyone who is willing to help newbies like me!
Lynnr
Member
 
Posts: 6
Joined: Sun Feb 21, 2016 5:45 pm

Re: Expression pedals don't work

Postby organsRgreat » Fri Feb 10, 2017 1:46 pm

I don't currently have the St. Anne's organ installed, so I googled for an image of the console. There appear to be two Swell pedals, but only one one set of stops I would expect to be controlled by a swell pedal (“under expression”) - those on the Swell manual. I think you may have inadvertently “auto-detected” the wrong pedal. Right click each pedal and read the resulting message carefully – I would guess that the one on the left is the true Swell pedal, whereas that on the right is a General Crescendo pedal for the whole organ.

The Great to Pedal lever will only duplicate on the pedals the stops you have already drawn on the Great manual. Try “pulling out” one stop on the Great, then apply the Great to Pedal coupler, and see if the manual stop now also sounds on the pedals. Quite likely the Great to Pedal will be reversible - successive operations will turn the control on, off, on etc.
organsRgreat
Member
 
Posts: 271
Joined: Fri Nov 16, 2012 6:30 am
Location: England

Re: Expression pedals don't work

Postby organsRgreat » Fri Feb 10, 2017 1:53 pm

If you do find that the wrong swell pedal is being operated, you can use Hauptwerk's command to “Clear all MIDI/trigger settings”, then choose the correct assignment. Hauptwerk will in any case warn you if you get this sort of thing wrong (for instance, if you assign two controls to one pedal), and give you a chance to put it right :-)
organsRgreat
Member
 
Posts: 271
Joined: Fri Nov 16, 2012 6:30 am
Location: England

Re: Expression pedals don't work

Postby mnailor » Fri Feb 10, 2017 2:58 pm

The right hand pedal on St. Annes is indeed the crescendo. The left hand pedal is the swell.
mnailor
Member
 
Posts: 332
Joined: Sat Nov 30, 2013 6:57 pm
Location: Atlanta, GA

Re: Expression pedals don't work

Postby organsRgreat » Fri Feb 10, 2017 5:56 pm

Thanks for the clarification – the helpfulness of fellow members of this forum (even on points of detail) never ceases to amaze me :-)
organsRgreat
Member
 
Posts: 271
Joined: Fri Nov 16, 2012 6:30 am
Location: England


Return to Free Edition support (users supporting users)

Who is online

Users browsing this forum: No registered users and 1 guest