Page 1 of 1

OSX 10.12.6 cannot install

PostPosted: Thu Oct 19, 2017 2:41 pm
by johnty
Hi there,

I'm trying out the free edition before deciding to purchase a full copy of the software, but am having trouble installing it.

Machine is a mid 2010 Mac Pro with quad core xeon, 8GB RAM. Downloaded and installed the legacy java runtime and the installer launches. After the step to enter the admin credentials, I see the two following behaviours:

1.) on a non-admin account, the installer seems to just disappear
2.) on an admin account, it seems to hang with 100% CPU/ not responding in Activity monitor.

This is a relatively fresh install of the OS. This may not be the actual machine I will use it on, but is one I'm testing with right now.

Any pointers appreciated. :)

Re: OSX 10.12.6 cannot install

PostPosted: Fri Oct 20, 2017 3:14 am
by mdyde
Hello Johnty,

Thanks very much for the interest in Hauptwerk.

In general, we do fully support Hauptwerk on macOS/OSX X 10.12.x Sierra, and we found no significant issues within Hauptwerk itself on that version, except that on Sierra the following apply:

1. (Which you've already done): Apple's Java for OS X (2015-001) needs to be installed before Hauptwerk's installer can run:

2. Unfortunately the recent macOS 10.12.2+ updates (which Apple released just before Christmas) have caused an issue whereby Hauptwerk's installer may sometimes crash after prompting you to enter your computer password. Addressing that properly is a matter of the highest possible priority for us, but at the moment we need to await a fix from the makers of the installer authoring software that we use for Hauptwerk. For now the work-around is simply to try re-launching the installer and trying again if has crashed. Usually it will work successfully after a small number of attempts, but if not then downloading the file again may help (since the issue appears to be related to macOS's check for the code signature, as a result of the file having been downloaded). It may take a little perseverance, but our experience is that it will always get past the login screen eventually, if you keep trying it (even without downloading it again). Our apologies for the issue.

Hence please just try re-launching the installer after it has disappeared, and it should eventually succeed.

Re: OSX 10.12.6 cannot install

PostPosted: Fri Oct 20, 2017 11:02 am
by johnty
Thanks for the reply!

I have since then tried it on two more machines (13" retina macbook also running 10.12.6) as well as windows 10.

The Windows 10 install went without a hitch, while the macbook had the same behaviour as the tower. Will try your suggestion and see if I can get it to work!

*edit* quick update: managed to launch the installer from the commandline (by manually executing the binary in the .app/Contents/MacOS folder). launching like this also avoided the need for admin login it seems (regular shell command, no sudo required)

Re: OSX 10.12.6 cannot install

PostPosted: Fri Oct 20, 2017 11:08 am
by mdyde
Thanks, Johnty.

Re: OSX 10.12.6 cannot install

PostPosted: Sat Nov 11, 2017 4:35 am
by Pascal
I had exactly the same problem also on OSX 10.12.6. I tried a lot of things like reinstall Java, restart computer and a new download. I was almost giving up but then the simple thing Martin suggested to just re-launching the installer right after it has disappeared, worked for me after only a few times.

Now I am looking forward to experience Hauptwerk :)

Re: OSX 10.12.6 cannot install

PostPosted: Sat Nov 11, 2017 6:28 am
by mdyde
Thanks, Pascal.

Glad to hear got it installed successfully. Hope you enjoy it.