Search:
Submit Search


Service call info - might be useful here

Connecting Hauptwerk to MIDI organs, sequencers, ...

Service call info - might be useful here

Postby engrssc » Fri Jul 07, 2017 9:28 pm

One of my clients (a church) had a sound system problem. Not organ this time - they (still) have a Rodgers.599 Seems they also have a DIY audio tech type who installed some new speakers. Initially everything looked okay, except the power amp Crown CT8150 was down. One of the power stages blew - literally with pieces scattered about inside the chassis. ((BTW you need special security bits to access the innards.) Looking further revealed the problem. Their techie ran shielded mic cable for the speaker feeds. (Aside from the speaker line (mismatch) of less than 1 ohm, it probably would have worked). No doubt the amp went into oscillation mode even tho that amp has many levels of protection. He had the input level cranked. Can't imagine how loud that must how been.

Anyway got Crown (Elkhart, IN) to repair the amp and ran good Belden 14 gauge speaker line to the added on spkrs. No problems now for 4 weeks. Amp died :cry: within a half hour of the original botched install.

Lessen - never run shielded speaker feed lines. :roll: Probably not the best idea to run such a low (less than 1 ohm) impedance from the speakers either. I balanced things so that more than one power amp shares the load. :wink:

Rgds,
Ed
User avatar
engrssc
Member
 
Posts: 5089
Joined: Mon Aug 22, 2005 11:12 pm
Location: Roscoe, IL, USA

Return to Audio / MIDI interfacing

Who is online

Users browsing this forum: No registered users and 2 guests