Search:
Submit Search


Midi connection on viscount organ

Connecting Hauptwerk to MIDI organs, sequencers, ...

Midi connection on viscount organ

Postby ChrisBr » Mon Oct 30, 2017 9:02 am

I have been trying to connect the free version of Hauptwerk to my Viscount
Jubileaum 232 organ. I have a focusrite scarlett 6i6 audi / midi interface,
but I can't get the organ to speak to hauptwerk. The midi interface is installed (Hauptwerk sees it), but the the
midi auto configure on Hauptwerk doesn't do anything after I have pressed the
keys as requested. I think I must be missing something; any suggestions? Thanks
ChrisBr
Member
 
Posts: 1
Joined: Mon Oct 30, 2017 7:25 am

Re: Midi connection on viscount organ

Postby mdyde » Mon Oct 30, 2017 10:33 am

Hello Chris,

[Topic moved here.]

Welcome to the forum and thanks again for the interest in Hauptwerk.

Looking back through previous communications with other Hauptwerk users, and based on some quick Internet searches, my understanding is that the Viscount Jubileum 232 is a model from around 1993 and that it does have MIDI (although I haven't so far been able to find a user manual on the Internet for one), and at least one person has used one successfully as a means from which to play Hauptwerk's virtual keyboards (although he said that using the Viscount's stop switches, pistons and swell pedal wasn't possible due to limitations of the model's MIDI implementation).

I also found this second-hand listing for one on Viscount's website, which corroborates that: https://viscountorgans.net/products/jubileum-232-25-speaking-stops-and-midi/ . I see also from that listing that it doesn't appear to have any separate 'MIDI' stop switches, so presumably its keyboards should always be transmitting MIDI.

That being the case, please try:

- Make sure that a genuine MIDI cable is connected from the MIDI OUT port on your Viscount to the MIDI IN port on your Focusrite Scarlett 6i6 interface.

- (Probably an obvious one: make sure that both the Viscount and the Scarlett are turned on!)

- Exit and re-launch Hauptwerk for good measure, just in case any MIDI devices might have changed. (Hauptwerk queries the list of MIDI ports from the computer's operating system when it launches and expects it to remain constant; it doesn't support 'hot-plugging' audio/MIDI devices.)

- Make sure that your Scarlett's MIDI IN port is ticked in the *left-hand* ('Console MIDI IN') column on the 'General settings | MIDI ports | MIDI IN ports' screen tab, and that nothing at all is ticked on the 'MIDI OUT ports' tab. OK the screen.

- Load the St. Anne's organ.

- Try right-click auto-detection again on the virtual Great manual, making sure you press (at least) the lowest and highest keys on your Viscount's Great manual, and also making sure that you don't accidentally touch any other controls or keyboards on the Viscount whilst doing so (which might result in confusing MIDI messages being heard).

- The Done button should become enabled if Hauptwerk has heard valid MIDI messages. Click it if so.

Does that solve it? If not, do any of the virtual MIDI activity LEDs flash on Hauptwerk's 'Audio, MIDI and Performance' large control panel ('View | Large floating control panels ...') as you press keys on the Viscount's Great manual? Which ones, if so?
Best regards,
Martin.

[Please use email or the Contact page if you need to contact us privately, rather than private forum messages.]

Image
User avatar
mdyde
Moderator
 
Posts: 10644
Joined: Fri Mar 14, 2003 2:19 pm
Location: UK

Re: Midi connection on viscount organ

Postby dhm » Mon Oct 30, 2017 10:57 am

Following on from Martin’s reply...
I used to have a Viscount “Grand Opera”, vintage c.1990 when I began my Hauptwerk journey.
I can confirm that the keyboards and pedal sent normal MIDI messages, but the stops, pistons and swell pedals sent no useable signals.
Douglas Henn-Macrae
Authorized Hauptwerk Reseller
http://www.midi-organs.eu / http://www.gundulf.org.uk
User avatar
dhm
Member
 
Posts: 971
Joined: Thu Jan 12, 2006 11:50 am
Location: Rochester, UK


Return to Audio / MIDI interfacing

Who is online

Users browsing this forum: No registered users and 1 guest