Search:
Submit Search


Clean and loud

Connecting Hauptwerk to MIDI organs, sequencers, ...

Clean and loud

Postby Rimokatolik » Mon Feb 05, 2018 8:18 pm

I have hard time achieving clean and loud sound using Hauptwerk on external speaker (Behringer UMC202HD, 1 DefTech Mythos STS). I am not expert on sound, so I would appreciate some help. I can listen to any sound (like videos, music, ...) louder then I would use regularly and sound is still clean, but if I try to make Hautpwerk loud I always hear clipping/distortion. I tried to make Hauptwerk increae decibels, make it loud either with a few or with many stops, pressing one or more keys, ..., no combination worked for me to get nice/clean and loud sound. Any ideas? Thank you in advance
Rimokatolik
Member
 
Posts: 28
Joined: Sat Dec 03, 2016 1:40 am

Re: Clean and loud

Postby mdyde » Tue Feb 06, 2018 5:29 am

Hello Rimotalik,

Do any of the meter's on Hauptwerk's 'Audio, MIDI and performance' control panel ('View | Large floating control panels ...' from the menu) go into (or nearly into) the red when the clipping/distortion occurs? Which ones, if so?

When the problem next occurs, if you'd like to use 'Help | Create a diagnostic file' and send the resulting file to us ( http://www.hauptwerk.com/forms/support/ ) then we could have a look to see if it gives any clues.
Best regards,
Martin.

[Please use email or the Contact page if you need to contact us privately, rather than private forum messages.]

Image
User avatar
mdyde
Moderator
 
Posts: 10644
Joined: Fri Mar 14, 2003 2:19 pm
Location: UK

Re: Clean and loud

Postby Rimokatolik » Sun Feb 25, 2018 5:55 am

I am sorry for the late reply. I am using headphones, and got busy with other things, so it took a while to verify.

Yes, you are right. CPU meter goes into red. I will need to investigate more why is that happening, as I don't expect it on this 12 cores + HT machine.

Thank you
Rimokatolik
Member
 
Posts: 28
Joined: Sat Dec 03, 2016 1:40 am

Re: Clean and loud

Postby mdyde » Sun Feb 25, 2018 6:37 am

Hello Rimotalik,

Thanks for the update.

The 'audio CPU' meter in Hauptwerk shows the amount of time that Hauptwerk is currently taking to calculate each chunk of sound, compared to the amount of time that the driver allowed it. I.e. it the meter specifically shows the risk of an audio glitch occurring.

First of all, I'd suggest:

- Make sure you have the latest BIOS installed for the PC's motherboard. Check on its manufacturer's website for the latest version, and how to install it, if relevant. That's very important, and can solve all manner of performance issues.

- Make sure you have all power-saving functions in the BIOS disabled, if relevant.

- Make sure all current operating system updates are installed on your new computer. (Use Windows Update to check for updates, apply all available, reboot, then keep repeating until there are no more. Note that you might need to click the 'check for updates' button *twice* before Windows actually performs the check.) (Please note, however, that the recent 'Windows 10 Fall Creators update' is known to cause organs to load and unload slower, so you might want to avoid that for now.)

- Make sure that you have the latest versions of the drivers and firmware installed for all of your hardware, especially your audio/MIDI interface(s) and graphics card, checking on the manufacturers' websites.

- Download and install the driver for the Hauptwerk USB key, the current version of which is always available on our main downloads page here: http://www.downloadhauptwerk.com/ . (It doesn't hurt to re-install it if you aren't sure whether you already have the current version.)

- Disable all Windows power-saving functions, including the options for putting USB ports/devices to sleep. For example, on Windows 10 you would use 'Windows Control Panel | System | Power and sleep | Additional power settings', select the 'High performance' power plan, then click its 'Change plan settings | Change advanced power settings', then make sure that the settings are set as follows:
- Sleep: Hibernate after = Never (for 'plugged in' if present)
- USB settings: USB selective suspend setting = Disabled (for 'plugged in' if present)
- PCI Express: Link state power management = Off (for 'plugged in' if present)
- Processor power management: Minimum processor state = 100% (for 'plugged in' if present)
- Hard disk: Turn off hard disk after = Never (for 'plugged in' if present)
... then OK all of the screens.

- Reboot if you updated anything.

- Make sure that that you have (the latest version of) your audio interface's manufacturer-supplied ASIO driver selected on Hauptwerk's 'General settings | Audio outputs' screen (*not* DirectSound).

- Make sure you aren't over-filling your PCs memory, if the problem only occurs with a large sample set (but doesn't occur with the St. Anne's, Moseley organ, for example).

- If Hauptwerk's 'audio CPU' meter is only going into the red when thousands of pipes are sounding at once then please see the 'Performance tuning' section in the main Hauptwerk user guide (pages 200-213 in the current v4.2.1 version), and especially the 'Summary: quick guidelines for troubleshooting audio or performance problems' subsection (page 213):

If the CPU meter is showing red then audio glitches are likely; make sure you're using a good-quality audio interface and have the latest manufacturer-supplied driver (ASIO on Windows) installed for it and selected on the General settings | Audio outputs screen, and that the audio buffer size isn't set too small (1024 or 512 should be safe). If the problem persists then use the adjustment buttons to reduce the polyphony limit on the control panel to lower the limit.


If those things don't solve it:

If Hauptwerk's audio-CPU meter is going into, or nearly into, the red when few or no pipes are sounding then it indicates that the audio driver/host is calling Hauptwerk too late for Hauptwerk to have time to calculate the audio before the hardware needs to play it (i.e. resulting in a 'buffer under-run'), either because the audio driver isn't performing properly, or because the PC is having underlying hardware/driver timing issues (e.g. DPC latency). The following utility should help to identify whether the latter is the issue, i.e. whether the PC and its drivers are performing sufficiently well to support real-time low-latency audio:

http://www.resplendence.com/latencymon

Leave it running (but without Task Manager being open) for half an hour or so whilst Hauptwerk is running with an organ loaded. LatencyMon needs to report that the PC is performing well enough for real-time audio before the PC will be able to work reliably for Hauptwerk (or any other real-time audio applications).

There are also some documents with more suggestions for troubleshooting PC audio problems here:

https://www.hauptwerk.com/clientuploads/documentation/Tutorials/WindowsOptimizationsAndDiagnostics.pdf
https://www.cantabilesoftware.com/glitchfree/
Best regards,
Martin.

[Please use email or the Contact page if you need to contact us privately, rather than private forum messages.]

Image
User avatar
mdyde
Moderator
 
Posts: 10644
Joined: Fri Mar 14, 2003 2:19 pm
Location: UK

Re: Clean and loud

Postby Rimokatolik » Mon May 21, 2018 7:34 pm

I have finally had a time to make progress, but it is still not ideal.

I have installed latest driver for my audio interface and now it respects HW setting, which prevents me to select variety of buffer sizes. In HW limit is 1100 something, but I would like to try 2048. Is there a way to enable more options for buffer size in HW?

Also after installing latest Windows update CPUs started again to vary in frequency, although all settings I have set before seem like preserved. Does anyone have idea what could have changed?

Thank you
Rimokatolik
Member
 
Posts: 28
Joined: Sat Dec 03, 2016 1:40 am

Re: Clean and loud

Postby B. Milan » Tue May 22, 2018 3:54 pm

1024 is the largest buffer size Hauptwerk allows for ASIO, since if the PC is working properly for real-time audio (as reported by LatencyMon) then a larger buffer size than that should never be needed or beneficial.
Regards,
Brett Milan
http://www.hauptwerk.com
http://www.milandigitalaudio.com
Send Email

Image

_________________________________
Please use email for contacting us. No private messages please.
User avatar
B. Milan
Site Admin
 
Posts: 4340
Joined: Sat Aug 30, 2003 11:15 am
Location: Tampa, FL. USA

Re: Clean and loud

Postby IainStinson » Thu May 24, 2018 6:31 am

The ASIO buffer size is sometimes not controlled through HW but through the device's control panel.
From the Windows optimisation tutorial
Try audio buffer sizes of 1024 and 512 in Hauptwerk on the General settings |
Audio outputs screen. Note that some audio interface drivers ignore the buffer
size that an application (such as Hauptwerk) requests, and instead always use
the buffer size set in their ASIO control panel. Hence you might instead need to
adjust the buffer size via their ASIO control panel, which can be accessed by
clicking the Show device control panel button on the General settings | Audio
outputs screen in Hauptwerk. You can determine which buffer size setting the
driver is using by looking for the buffer size shown in the Hauptwerk log (use
Hauptwerk - Other operating system and computer optimizations and diagnostics
Help | View activity log in Hauptwerk, then look at the latest INF:5152 line), or by
looking on the Audio, MIDI and Performance large control panel.


Also look at http://forum.hauptwerk.com/viewtopic.php?f=4&t=16774&p=126113&hilit=buffer#p126113

For Windows systems you should also follow the advice in https://www.hauptwerk.com/clientuploads/documentation/Tutorials/WindowsOptimizationsAndDiagnostics.pdf

Hope this is helpful.
Iain
User avatar
IainStinson
Member
 
Posts: 571
Joined: Tue Dec 29, 2009 7:08 pm
Location: NW England, UK


Return to Audio / MIDI interfacing

Who is online

Users browsing this forum: No registered users and 2 guests