Search:
Submit Search


Midisport 4x4 Anniversary Edition and drivers

Connecting Hauptwerk to MIDI organs, sequencers, ...

Midisport 4x4 Anniversary Edition and drivers

Postby Timo » Thu Mar 08, 2018 5:12 pm

Thought to let you know my latest finding. I have a Consolo console and M-Audio Midisport 4x4 Anniversary Edition as MIDI adapter. The computer has Windows 10 version 1703 with MIDISPORT Windows Driver v6.1.3. The sound card is Maya44 XTe PCIe adapter, which is pretty good and fairly priced soundcard with two headphone outputs, but this is not significant for this case.

This system operates normally very well and I have not had a single stuck key. The problem is with big number of register changes by presets. This console has an internal registration memory which can cause up to 72 program change MIDI messages very tightly together. When switching a tutti on, about dozen registers remain inactivated. Same thing when setting all registers off.

So I started to tinker this with another computer and MIDI-OX. This other computer showed regularly all 72 messages on midi-ox when running my all on - all off - all on test repeatedly. So I installed midi-ox to my playing computer and clearly one to two dozen messages were randomly lost. Next, I uninstalled Midisport drivers and booted the computer up. This time the all on - all off test worked perfectly. So I left the system this way.

The Midisport USB adapter seems to be good and reliable device but I cannot recommend to use the drivers provided by M-AUDIO in their download site for it.

Timo.
Timo
Member
 
Posts: 17
Joined: Thu Sep 14, 2006 5:17 pm
Location: Finland, Helsinki

Return to Audio / MIDI interfacing

Who is online

Users browsing this forum: No registered users and 5 guests