Search:
Submit Search


MIDI stops working

Connecting Hauptwerk to MIDI organs, sequencers, ...

MIDI stops working

Postby John L » Wed May 16, 2018 5:08 am

Every now and again, usually when I'm away from the console, occasionally while playing, the Hauptwerk MIDI interface just stops working on all channels, input and output, for no apparent reason. I then do a "Reset organ/MIDI" and all is OK again.

As far as I can tell there is nothing wrong with the MIDI feed. There are no error messages, either from the application or from Windows.

Any suggestions for where to start with diagnostic work?

W7
HW 4.2.1.003 advanced
MIDI > Scarlett 6i6 audio/MIDI > USB > PC USB 2 port

Thanks.

John.
John L
Member
 
Posts: 23
Joined: Wed Jan 18, 2017 9:33 am
Location: Cumbria UK

Re: MIDI stops working

Postby IainStinson » Wed May 16, 2018 5:41 am

As your interface connects via USB, make sure that the power savings settings for your Windows system are set to never power down the USB ports. It may be that when the system is idle it is turning off the USB ports to save power.

Iain
User avatar
IainStinson
Member
 
Posts: 624
Joined: Tue Dec 29, 2009 7:08 pm
Location: NW England, UK

Re: MIDI stops working

Postby John L » Sun May 20, 2018 5:50 am

Thanks for the quick reply Iain and my apologies for the slow acknowledgement, for some reason I didn't get the reply notification (edit: ahha, it seems one has to subscribe, even for threads one has started).

I had discounted USB power as a potential source of the problem because it would occasionally occur in-flight, so to speak. However I have now disabled all USB power controls and will see what happens. It may take a while to be sure as the problem is highly erratic.

Another thought occurred to me while I was reading your very interesting web site. My system is connected to t'Internet at all times so it might be that something "out there" is the cause. I'm running W7 and only download/install updates manually, so I don't think it's Windows Update causing the problem. I'll try disabling the Ethernet port if the problem persists.

Thanks again for your suggestion.

John.
John L
Member
 
Posts: 23
Joined: Wed Jan 18, 2017 9:33 am
Location: Cumbria UK

Re: MIDI stops working

Postby John L » Wed Aug 22, 2018 9:40 am

Update:

I eventually traced the problem to Windows Update announcements. I have the W7 machine set to just notify, not download or install, which I do at a convenient time. Just the update announcement is enough to kill the MIDI interface, which seems rather odd. Anyhow, the workaround is simple enough... only connect to t'Internet when not trying to make music.
John L
Member
 
Posts: 23
Joined: Wed Jan 18, 2017 9:33 am
Location: Cumbria UK

Re: MIDI stops working

Postby robsig » Fri Aug 24, 2018 11:01 am

Since the beginning (2014) I have had this problem with Scarlet 6i6 stopping for no apparent reason, always while playing. The computer is not connected to the internet. It happens only 4-5 times a year, with few or lots of stops, different sample-sets, different pieces. I just live with it. Twice it happened just before a performance on stage with an orchestra. A relaunch cleared up the problem just in time. It has never quit during performance, but the fear is always there…

I have never found a solution, I just live with it…

Windows 7 professional, 3 Midiworks manuals, 32 G memory. The computer has no other background activities or processes.

RS
robsig
Member
 
Posts: 48
Joined: Tue Apr 08, 2014 2:55 pm

Re: MIDI stops working

Postby engrssc » Fri Aug 24, 2018 12:02 pm

What are you using for an encoder? Tried changing MIDI cables? MIDI to computer via uSB? Have you tried different USB ports? Observed MIDI activity via MIDI Ox? Do just manuals quit? Stops/pistons quit also? Have you tried same setup with a different computer? Since it happens so seldom, difficult to trace. Is the setup headless? Tried different RAM? Tried different HDD (or SSD)?

Rgds,
Ed
User avatar
engrssc
Member
 
Posts: 5530
Joined: Mon Aug 22, 2005 11:12 pm
Location: Roscoe, IL, USA

Re: MIDI stops working

Postby robsig » Sat Aug 25, 2018 10:45 am

The problem occurs on two different computers, one a PC designed and dedicated to HW without Internet connections and a Macbook Pro, thus two sets of RAM, HD, cables, even keyboards!. Different sample sets as well. Different venues as well, so it's not the power supply to the house.

I do share the same interface for both setups. (Scarlet 6i6, as mentioned). The problem must be in the Scarlet unit or the associated drivers, although one is Mac and the other PC. Or maybe some setting in HW such as polyphony?

I stopped exploring the glitch some time ago and just live with it. It takes a couple of minutes to reboot so it's not that big a deal.

By the way, the support team at Scarlet couldn't find an explanation and they had had very few similar complaints in spite of thousands of similar units distributed throughout the world.

I figure it's karma…

RS
robsig
Member
 
Posts: 48
Joined: Tue Apr 08, 2014 2:55 pm

Re: MIDI stops working

Postby engrssc » Sat Aug 25, 2018 11:11 am

Since the Scarlet 6i6 seems to be the common denominator, is there a reason you can't change it?

Rgds,
Ed
User avatar
engrssc
Member
 
Posts: 5530
Joined: Mon Aug 22, 2005 11:12 pm
Location: Roscoe, IL, USA

Re: MIDI stops working

Postby John L » Sat Aug 25, 2018 12:02 pm

That's curious, robsig. As Ed says, the common denominator seems to be the Scalett 6i6 but I am using the 6i6 here and since I disabled the Internet I've had no problems to date on my W7-based system.

When you say you have to reboot, do you really reboot the system, or are you just resetting the MIDI interface in HW? I found that the MIDI reset worked for me every time.

I am not yet completely convinced that HW itself is totally out of the equation - it is, after all HW that loses the MIDI connection and HW seems to be able to reset it. MIDI is such a simple serial interface that there is really not too much to go wrong with it. The problem is that the problem happens so infrequently that it is nearly impossible to troubleshoot.

Regards,

John.
John L
Member
 
Posts: 23
Joined: Wed Jan 18, 2017 9:33 am
Location: Cumbria UK

Re: MIDI stops working

Postby jkinkennon » Sun Aug 26, 2018 11:28 am

Windows Update is the likely culprit based on my own experience. I've been without a console for several months now but I recall having to disable all updates on Windows 10 for reliable operation. Too many projects going on plus two consoles nearly finished in the garage so I'll be playing one of them very soon. I do wish that Microsoft had a better appreciation of how unwelcome the many notifications can become. When working on the consoles in the garage I get notified about new devices being set up any time I power on a console -- I'm sure I can turn that off somewhere...
jkinkennon
Member
 
Posts: 988
Joined: Thu May 07, 2009 10:43 am
Location: Vancouver, WA

Re: MIDI stops working

Postby B. Milan » Mon Aug 27, 2018 8:46 pm

[Topic moved]
Regards,
Brett Milan
http://www.hauptwerk.com
http://www.milandigitalaudio.com
Send Email

Image

_________________________________
Please use email for contacting us. No private messages please.
User avatar
B. Milan
Site Admin
 
Posts: 4348
Joined: Sat Aug 30, 2003 11:15 am
Location: Tampa, FL. USA


Return to Audio / MIDI interfacing

Who is online

Users browsing this forum: No registered users and 2 guests