It is currently Tue Jul 16, 2024 11:41 am


Midi input problem with moto micro lite

Connecting Hauptwerk to MIDI organs, sequencers, ...
  • Author
  • Message
Offline

stephen_munich

Member

  • Posts: 4
  • Joined: Wed May 13, 2020 1:45 pm
  • Location: Munich, Germany

Midi input problem with moto micro lite

PostWed May 13, 2020 2:20 pm

Hi everyone,
I took the plunge and upgraded to HW5 this week.
I first created a clean install of MacOS 10.15.4 (Catalina) on my MacPro (2013).
I mastered the issues with iLok and transferring the licenses (advanced, Salisbury) from the old dongle.
I even bought Hereford as a treat.
my old M-Audio Midisport is no longer supported. I therefore bought the moto micro lite midi interface, which arrived today.
I used the (latest) moto drivers for Catalina from October 2019. v1.6 (82544).

Unfortunately, now my console won‘t play.

I checked the security pane in System preferences, but no issue there.
I have looked in the macOS midi setup.
The micro lite is correctly recognizedband online.
Have reinstalled the moto drivers. Deleted the preferences file for midi setup. Created a new configuration. Restarted the computer several times. No change.

The test feature in midi setup can trigger all 5 midi OUT ports: Green lights flash on the hardware, signals confirmed using midi monitor.

When moving keys, stops, pistons, etc., the midi INPUT ports flash (orange) on the Micro lite hardware, but nothing arrives in software, not Hauptwerk, not midi setup, not midi monitor.

Any suggestions?
Offline
User avatar

micdev

Site Admin

  • Posts: 2102
  • Joined: Sat Feb 09, 2008 9:24 am
  • Location: Canada, Quebec

Re: Midi input problem with moto micro lite

PostWed May 13, 2020 4:14 pm

Hello Stephen,

Have you read the Motu technical note on motu website?https://motu.com/techsupport/technotes/enabling-motu-drivers-high-sierra

If you test with midi monitor - https://www.snoize.com/MIDIMonitor/ do you get midi messages?

Have you checked Hauptwerk midi settings - General settings | Midi ports | Midi IN ports . Is the box next to your midi interface ticked (Console midi in column)?

I'm sure that you have "auto-detected" your keyboards?

If your console is a Rodgers, Allen etc, there is usually a tab/stop to activate midi for each divisions. Are they set properly?

Hope this helps
Best regards
François

Virtually sharing my enthusiasm and experience with you
Worldwide technical assistance, consultation and ready to play system.

http://www.HauptwerkConsultant.com

AND Hauptwerk Support Manager
Offline

stephen_munich

Member

  • Posts: 4
  • Joined: Wed May 13, 2020 1:45 pm
  • Location: Munich, Germany

Re: Midi input problem with moto micro lite

PostWed May 13, 2020 6:09 pm

Hi François,

Yes, had tried all that.
The problem is much more curious.

It would seem to be an incompatibility with a Logitech USB extender. The extender worked with the previous midi interface, also when fed through a touchscreen‘s powered usb hub.
So it would seem that the Moto device can be in a state where it is recognized by the macOS, can receive signals from the Mac and output to midi, but not forward midi IN signals to macOS.
I just managed to connect three USB extensions together, connecting the moto micro lite „directly“ to the Mac without the usb extender, and it worked.
Curious that it gives a green light, but doesn‘t work when routed via the usb extender...
And still works when on a long cable with multiple connectors (but no extender).
Have ordered a different usb extender from digitech to compare, because I normally run the usb through cat6 cables buried in the floor...
Offline
User avatar

micdev

Site Admin

  • Posts: 2102
  • Joined: Sat Feb 09, 2008 9:24 am
  • Location: Canada, Quebec

Re: Midi input problem with moto micro lite

PostWed May 13, 2020 7:50 pm

Glad you found the fix.

USB extender can be indeed tricky and sometimes made for computer keyboard/mouse and not musical instruments. USB 2 specifications recommend to keep the cable length below 16' (5 meters), USB3 below 10' (3 meters). Of course you can go longer, but may experiment all kind of glitches.
Best regards
François

Virtually sharing my enthusiasm and experience with you
Worldwide technical assistance, consultation and ready to play system.

http://www.HauptwerkConsultant.com

AND Hauptwerk Support Manager
Offline
User avatar

engrssc

Member

  • Posts: 7283
  • Joined: Mon Aug 22, 2005 10:12 pm
  • Location: Roscoe, IL, USA

Re: Midi input problem with moto micro lite

PostWed May 13, 2020 8:23 pm

I did an installation using a Gefen EXT-USB2.0-LR Cat5 USB 2.0 Extender system a little over 3 years ago. The distance between the transmitter and receiver is approx 200 feet (61 m) using Cat 5e with zero problems. The computer is a Mac Mini. Don't remember which OS. That system requires both the transmitter and the receiver to be powered.

https://www.bhphotovideo.com/c/product/593770-REG/Gefen_EXT_USB2_0_LR_EXT_USB2_0_LR_Cat5_USB_2_0.html/?ap=y&ap=y&smp=y&smp=y&lsft=BI%3A514&gclid=EAIaIQobChMI7r_Ho5my6QIVxcDACh24NQIeEAQYASABEgJO2vD_BwE

Rgds,
Ed

Return to Audio / MIDI interfacing

Who is online

Users browsing this forum: No registered users and 6 guests