It is currently Thu Apr 09, 2020 8:01 pm


P341 percussion sounds only trigger every other time

Hauptwerk software technical support only. Please make sure you have read the manual, tutorials and FAQ pages before requesting support.
  • Author
  • Message
Offline
User avatar

fchazz

Member

  • Posts: 76
  • Joined: Fri Apr 11, 2014 4:37 pm
  • Location: Leesburg Florida

P341 percussion sounds only trigger every other time

PostWed Mar 25, 2020 2:09 pm

On my p341 when triggering a percussion sound from a midi controller such as a launchpad or fcb1010 it will only trigger the sound on every other push of the control rather than every time. I don't see an adjustment for this. It triggers properly when I click the button on the gui.
Any thoughts?
I am running advanced V5 on OSX.
Offline
User avatar

mdyde

Moderator

  • Posts: 11855
  • Joined: Fri Mar 14, 2003 2:19 pm
  • Location: UK

Re: P341 percussion sounds only trigger every other time

PostWed Mar 25, 2020 2:22 pm

Hello Frank,

When auto-detecting the buttons/pistons, make sure you press and then release the MIDI piston, and that the 'toggle' option is *not* ticked on the auto-detecting screen.
Best regards, Martin.
Hauptwerk software designer/developer, Milan Digital Audio.

[Please use email or the Contact page if you need to contact us privately, rather than private forum messages.]
Offline
User avatar

fchazz

Member

  • Posts: 76
  • Joined: Fri Apr 11, 2014 4:37 pm
  • Location: Leesburg Florida

Re: P341 percussion sounds only trigger every other time

PostWed Mar 25, 2020 3:31 pm

That is what I do to set it up and the toggle option is not ticked and is infact greyed out. Still does it.
When I tie the gui button to a note on my keyboard it works like it should with the toggle option showing up. I dont get that option with the beringer fcb1010 buttons. I am now getting the toggle option on the launchpad.

So it is just not working with my Beringer fcb1010. Dont know if you are familiar with this piece of equipment.

I dont have the toggle option when using the beringer fcb1010
Offline
User avatar

micdev

Site Admin

  • Posts: 1598
  • Joined: Sat Feb 09, 2008 10:24 am
  • Location: Canada, Quebec

Re: P341 percussion sounds only trigger every other time

PostWed Mar 25, 2020 5:55 pm

Hello Frank

When I tie the gui button to a note on my keyboard it works like it should with the toggle option showing up.


So this means that "Note on/off" is the message expected. Have a look at your user manual or download it from this link

https://media63.musictribe.com/media/PLM/data/docs/P0089/FCB1010_P0089_M_EN.pdf

and go page 9 "Programming note function". Just make sure that you're not using the same midi channel as one of your keyboards/pedalboard.

Should work....

Regards
Best regards
François

Virtually sharing my enthusiasm and experience with you
Worldwide technical assistance, consultation and ready to play system.

http://www.HauptwerkConsultant.com

AND Hauptwerk Support Manager
Offline
User avatar

fchazz

Member

  • Posts: 76
  • Joined: Fri Apr 11, 2014 4:37 pm
  • Location: Leesburg Florida

Re: P341 percussion sounds only trigger every other time

PostSat Mar 28, 2020 10:33 am

OK, I have found that the way my fcb1010 is set up is Not where the problem is.... I think there may be a bug in the P341. I have my P320 set up exactly the same way as my P341. The buttons on my fcb1010 trigger every time I push them for the roll cymbal on my P320. Not the case for my P341. They only trigger every other time they are pressed for the roll cymbal1 and the bell tree.
So.... If they are set up exactly the same way shouldnt I expect them to behave the same way?
Offline

smfrank

Member

  • Posts: 230
  • Joined: Sun Dec 20, 2009 10:53 am
  • Location: NY, NY

Re: P341 percussion sounds only trigger every other time

PostSat Mar 28, 2020 10:49 am

fchazz wrote:They only trigger every other time they are pressed

Did you accidentally check "toggle" when you did auto-detect?
Steve
Offline
User avatar

mdyde

Moderator

  • Posts: 11855
  • Joined: Fri Mar 14, 2003 2:19 pm
  • Location: UK

Re: P341 percussion sounds only trigger every other time

PostSat Mar 28, 2020 10:54 am

Hello Frank,

If you'd like us to help you with it, then please:

- On the 'General settings | General preferences | Advanced ...' screen tab, turn on the 'Diagnostics: log all MIDI messages ...' option. OK the screen.

- Load the Paramount 320.

- Without touching anything else, press, then release, one of your FCB1010's buttons that controls a Paramount 320 percussion sound.

- Without touching anything else, press, then release, the same button again.

- Without touching anything else, load the Paramount 341.

- Without touching anything else, press, then release, the same one of the FCB1010's buttons that controls a Paramount 341 percussion sound.

- Without touching anything else, press, then release, the same button again.

- Without touching anything else, use 'Help | Create a diagnostic file' and send it to us via support [at] hauptwerk.com.

That will allow us to see exactly what MIDI messages your FCB1010's button is sending, what your MIDI settings are for the corresponding Paramount percussion buttons, and what is getting triggered when you press the FCB1010's button in each case.
Best regards, Martin.
Hauptwerk software designer/developer, Milan Digital Audio.

[Please use email or the Contact page if you need to contact us privately, rather than private forum messages.]
Offline
User avatar

fchazz

Member

  • Posts: 76
  • Joined: Fri Apr 11, 2014 4:37 pm
  • Location: Leesburg Florida

Re: P341 percussion sounds only trigger every other time

PostSat Mar 28, 2020 11:19 am

Martin, I sent you the file.
Offline
User avatar

mdyde

Moderator

  • Posts: 11855
  • Joined: Fri Mar 14, 2003 2:19 pm
  • Location: UK

Re: P341 percussion sounds only trigger every other time

PostSat Mar 28, 2020 2:41 pm

Thanks, Frank.

I can see that your FCB1010's button is sending a MIDI program change message as you press the button in, and then sending the same MIDI program change message as you release it:

P320:

2020-03-28-11-12-16: INF:2552 Diag: IN: MIDI program change: port: micro lite: Port 3, channel (1-16): 01, program number (1-128): 005. (Raw hex bytes: C0 04.)

2020-03-28-11-12-16: INF:2670 Diag: IN (derived): virtual switch toggled by MIDI/key input event: 002602 'Stop: Cymbal Roll'.

2020-03-28-11-12-16: INF:2563 Diag: OUT: MIDI program change: port: USB Keystation 61es, channel (1-16): 01, program number (1-128): 005. (Raw hex bytes: C0 04.)

2020-03-28-11-12-21: INF:2552 Diag: IN: MIDI program change: port: micro lite: Port 3, channel (1-16): 01, program number (1-128): 005. (Raw hex bytes: C0 04.)

2020-03-28-11-12-21: INF:2670 Diag: IN (derived): virtual switch toggled by MIDI/key input event: 002602 'Stop: Cymbal Roll'.


P341:

2020-03-28-11-13-45: INF:2552 Diag: IN: MIDI program change: port: micro lite: Port 3, channel (1-16): 01, program number (1-128): 005. (Raw hex bytes: C0 04.)

2020-03-28-11-13-45: INF:2670 Diag: IN (derived): virtual switch toggled by MIDI/key input event: 002606 'Cheek Button: Cymbal Roll I'.

2020-03-28-11-13-45: INF:2563 Diag: OUT: MIDI program change: port: micro lite Port 3, channel (1-16): 01, program number (1-128): 005. (Raw hex bytes: C0 04.)

2020-03-28-11-13-50: INF:2552 Diag: IN: MIDI program change: port: micro lite: Port 3, channel (1-16): 01, program number (1-128): 005. (Raw hex bytes: C0 04.)

2020-03-28-11-13-50: INF:2670 Diag: IN (derived): virtual switch toggled by MIDI/key input event: 002606 'Cheek Button: Cymbal Roll I'.


Although your MIDI settings are indeed the same for the two virtual controls, presumably the two virtual controls are implemented slightly differently in those Paramount organs (e.g one designated as latching, the other not).

Either way, the MIDI implementation that your FCB1010 is currently sending from that button (MIDI program changes sent twice -- once as the button is pressed in, and then again as it's released) isn't really appropriate. I recommend reconfiguring it (for all of its buttons) to send MIDI note-on/off messages, as Francois suggested, then auto-detecting them again.
Best regards, Martin.
Hauptwerk software designer/developer, Milan Digital Audio.

[Please use email or the Contact page if you need to contact us privately, rather than private forum messages.]
Offline
User avatar

fchazz

Member

  • Posts: 76
  • Joined: Fri Apr 11, 2014 4:37 pm
  • Location: Leesburg Florida

Re: P341 percussion sounds only trigger every other time

PostSat Mar 28, 2020 3:18 pm

Thanks Martin. I will see if I can get that done. It looks rather complicated.
Offline
User avatar

mdyde

Moderator

  • Posts: 11855
  • Joined: Fri Mar 14, 2003 2:19 pm
  • Location: UK

Re: P341 percussion sounds only trigger every other time

PostSat Mar 28, 2020 3:26 pm

Thanks, Frank.
Best regards, Martin.
Hauptwerk software designer/developer, Milan Digital Audio.

[Please use email or the Contact page if you need to contact us privately, rather than private forum messages.]
Offline
User avatar

fchazz

Member

  • Posts: 76
  • Joined: Fri Apr 11, 2014 4:37 pm
  • Location: Leesburg Florida

Re: P341 percussion sounds only trigger every other time

PostSat Mar 28, 2020 4:40 pm

Wow, I cant thank you Martin and Francois enough! This has been bugging me for some time now! It was some what of a river dance with all of the button pushing you have to do to programm the fcb1010 but it was sucessful! They are now working as they should.
Once again thank you very much!
Frank Hazzard
Offline
User avatar

mdyde

Moderator

  • Posts: 11855
  • Joined: Fri Mar 14, 2003 2:19 pm
  • Location: UK

Re: P341 percussion sounds only trigger every other time

PostSat Mar 28, 2020 4:53 pm

Thanks very much, Frank. Excellent.
Best regards, Martin.
Hauptwerk software designer/developer, Milan Digital Audio.

[Please use email or the Contact page if you need to contact us privately, rather than private forum messages.]

Return to Technical support

Who is online

Users browsing this forum: No registered users and 3 guests