It is currently Thu Apr 15, 2021 12:01 pm


Licence transfer help

Hauptwerk software technical support only. Please make sure you have read the manual, tutorials and FAQ pages before requesting support.
  • Author
  • Message
Offline

Coenraads

Member

  • Posts: 33
  • Joined: Fri Feb 01, 2019 10:13 pm

Licence transfer help

PostSun Mar 28, 2021 3:25 pm

I wish to transfer my Silbermann licence to a friend. We are currently both running HW4. I purchased HW2 on Mar. 20, 2006 (early adopter) Ser. No. 1905. Subsequently I purchased the Silbermann sample set and duly updated the dongle. I sent him both the sample set and the dongle. The dongle lights up and flickers when he loads HW, but it comes back with error 1333 (valid licence not found). Help! John Coenraads
Offline
User avatar

micdev

Site Admin

  • Posts: 1990
  • Joined: Sat Feb 09, 2008 9:24 am
  • Location: Canada, Quebec

Re: Licence transfer help

PostSun Mar 28, 2021 4:30 pm

Hello John,

Humm... if you are both using Hauptwerk 4 and you sent him your Hauptwerk 4 dongle (and Silbermann DVD) it should work.

Make sure that he disconnects *his* Hauptwerk 4 dongle from the computer and then connect *your HW4" dongle (while Hauptwerk is not loaded). He can then Hauptwerk and load the Silbermann.

Note that he will need to exit Hauptwerk and change the dongle when switching organ an organ that he owns (registered on his dongle).
Best regards
François

Virtually sharing my enthusiasm and experience with you
Worldwide technical assistance, consultation and ready to play system.

http://www.HauptwerkConsultant.com

AND Hauptwerk Support Manager
Offline
User avatar

mdyde

Moderator

  • Posts: 13196
  • Joined: Fri Mar 14, 2003 1:19 pm
  • Location: UK

Re: Licence transfer help

PostMon Mar 29, 2021 3:40 am

Hello John,

To add to Francois' reply, also make sure that your friend has the driver for the v4 Hauptwerk USB Key (HASP dongle) installed. The light within the dongle should light up constantly if the driver is 'seeing' the dongle; if it's flashing then the driver isn't seeing it (or isn't installed).
Best regards, Martin.
Hauptwerk software designer/developer, Milan Digital Audio.
Offline

Mikey

Member

  • Posts: 3
  • Joined: Mon Mar 29, 2021 11:39 pm

Re: Licence transfer help

PostWed Apr 07, 2021 10:35 pm

Sorry for the slow reply; I'm just helping from a distance with the system Coenraads is asking about. We've tried just the "new" dongle with the Silbermann organ but the system doesn't work properly when the original dongle is not present (mouse doesn't work properly, haupwerk won't boot).

The LED indicator on the Silbermann dongle does light up but it still doesn't work.

Although John said the dongle had been updated, could it be that it requires further updates? I have written software that uses those before and am aware that they can contain extra information that may need updating.

I believe the computer is a Windows 7 box and know for sure all it has ever run is Hauptwerk.

I had also looked in the device manager and could see both dongles are happily recognized by Windows.

I'm not sure what else to do. I'm prepared to go out there on the weekend to personally look at the system again. We'd really, really like to get this working.

Thank you for your help!
Mike
Offline
User avatar

engrssc

Member

  • Posts: 6927
  • Joined: Mon Aug 22, 2005 10:12 pm
  • Location: Roscoe, IL, USA

Re: Licence transfer help

PostThu Apr 08, 2021 3:08 am

deleted
Last edited by engrssc on Thu Apr 08, 2021 3:17 am, edited 1 time in total.
Offline
User avatar

engrssc

Member

  • Posts: 6927
  • Joined: Mon Aug 22, 2005 10:12 pm
  • Location: Roscoe, IL, USA

Re: Licence transfer help

PostThu Apr 08, 2021 3:16 am

Without any dongles connected, does the computer boot and operate (normally)? Not sure what you mean when you say mouse won't work properly? When you say Windows "sees" both dongles, each one connected separately?

I'm sure you are aware both Win 7 and Hauptwerk 4 are no longer supported and no further updates are available for either.

Rgds,
Ed
Offline
User avatar

mdyde

Moderator

  • Posts: 13196
  • Joined: Fri Mar 14, 2003 1:19 pm
  • Location: UK

Re: Licence transfer help

PostThu Apr 08, 2021 3:34 am

Hello Mike,

Briefly (since Hauptwerk v4 is no longer officially supported), to add to Ed's reply, I'd suggest:

- Make sure that you only have one Hauptwerk v4 (HASP) dongle attached to the computer at a time, and that it (and only it) is attached before launching Hauptwerk. Perhaps having two attached might cause some problem with the driver (or there might be insufficient USB power for both, or something like that).

- Make sure that all available Windows updates for the relevant operating system version (e.g. Windows 7) are installed. (Perhaps the HASP driver, or dongle firmware isn't compatible with some earlier Windows components.)

- Likewise make that the PC's BIOS is up to date.

- Make sure you have the current version of the HASP driver installed. Maybe John has an older version installed that isn't compatible with the firmware version within the relevant dongle. I'm not sure whether MDA still hosts the file publicly, but it can be downloaded from its makers here:

Windows HASP run-time environment v8.15 GUI installer: https://supportportal.gemalto.com/csm/? ... =KB0018320

macOS HASP run-time environment v8.16 GUI installer: https://supportportal.gemalto.com/csm/? ... =KB0018323
Best regards, Martin.
Hauptwerk software designer/developer, Milan Digital Audio.
Offline

Mikey

Member

  • Posts: 3
  • Joined: Mon Mar 29, 2021 11:39 pm

Re: Licence transfer help

PostThu Apr 08, 2021 8:29 am

>Not sure what you mean when you say mouse won't work properly?

I'm told that the mouse doesn't work at all if the original Hauptwerk dongle is absent. This shouldn't be happening; I'll need to see that for myself. Thinking about this just now, it is a wireless keyboard/mouse and it's possible there's enough confusion there that the keyboard/mouse dongle has been removed as well despite it being very tiny and labelled "Logitech". Until now, I had thought that this would certainly not have been removed...

>When you say Windows "sees" both dongles, each one connected separately?

Yes, when used seprately and together.

I'll need to look at it myself on the weekend.

Thank you for your comments!
mp
Offline
User avatar

engrssc

Member

  • Posts: 6927
  • Joined: Mon Aug 22, 2005 10:12 pm
  • Location: Roscoe, IL, USA

Re: Licence transfer help

PostThu Apr 08, 2021 8:43 am

I use a wireless keyboard/mouse which works correctly with or without a HASP or iLok dongle being connected.

Mikey wrote:When you say Windows "sees" both dongles, each one connected separately?

Yes, when used separately and together.


As Martin said, you don't want two (both) dongles connected at the same time.

You might want to download a fresh copy of the dongle to a flash drive ahead of your trip.

mdyde wrote:Windows HASP run-time environment v8.15 GUI installer:
https://supportportal.gemalto.com/csm/? ... =KB0018320

macOS HASP run-time environment v8.16 GUI installer:
https://supportportal.gemalto.com/csm/? ... =KB0018323


Rgds,
Ed
Offline

OrganoPleno

Member

  • Posts: 628
  • Joined: Thu Dec 03, 2009 4:08 pm

Re: Licence transfer help

PostThu Apr 08, 2021 12:01 pm

Coenraads wrote:I wish to transfer my Silbermann licence to a friend. We are currently both running HW4. I purchased HW2 on Mar. 20, 2006 (early adopter) Ser. No. 1905.


Maybe your Dongle contains a License for HW version 2, and his System is running HW version 4? This would explain why his system claims "no license is present" when reading the Dongle from the older HW-2 System.
Offline

Mikey

Member

  • Posts: 3
  • Joined: Mon Mar 29, 2021 11:39 pm

Re: Licence transfer help

PostSun Apr 11, 2021 6:55 pm

Got it sorted out; thank you all for your help!
Offline
User avatar

mdyde

Moderator

  • Posts: 13196
  • Joined: Fri Mar 14, 2003 1:19 pm
  • Location: UK

Re: Licence transfer help

PostMon Apr 12, 2021 3:06 am

Thanks, Mike.

Excellent.
Best regards, Martin.
Hauptwerk software designer/developer, Milan Digital Audio.

Return to Technical support

Who is online

Users browsing this forum: No registered users and 2 guests