Page 1 of 1

Jumper stepper

PostPosted: Mon Nov 05, 2018 10:34 pm
by profeluisegarcia
Hello all¡
My stepper pistons were working Ok: from xx0 to xx1 to xx2 and reverse. All of a sudden, they started jumping from xx0 to xx2, to xx4, to xx6 and so on.
I am -as always- almost sure that I had not touch any control . So, What I did? What do I have to do to solve the issue?
(BTW, this chapter about registration has not been easy to grasp for me).


Re: Jumper stepper

PostPosted: Tue Nov 06, 2018 5:27 am
by IainStinson
I would suggest checking the stepper increments using the advance > and back < buttons on the registration control panel. If these work as expected then it may be that your stepper advance and back pistons are sending the incorrect code - you should consider auto detecting them again. Make sure they have the appropriate “action” I.e. not toggle.

You might also check if the pistons are sending multiple messages when pressed (dirty contacts can cause this sometimes).


Re: Jumper stepper

PostPosted: Tue Nov 06, 2018 11:10 pm
by profeluisegarcia
Thanks Lain.
In the registration control panel, the generals advance in the right order: xx0-xx1-xx2... I have done what you suggest , but the issue persists when I use the pistons: xx0-xx2-xx4


Re: Jumper stepper

PostPosted: Wed Nov 07, 2018 9:20 am
by GrahamH
Hi Luis

MidiOx (for Windows - presumably there is an equivalent for Macs) will tell you if your pistons are sending multiple messages.


Re: Jumper stepper

PostPosted: Wed Nov 07, 2018 12:29 pm
by IainStinson
If you don't want to use MidiOx (or similar) you can see the midi data being sent using HW's midi logging.

With an organ loaded selected
General settings (on the main menu bar) then
General Preferences then
Advanced preferences
towards the bottom of the window tick the box before "diagnostics: log all MIDI messages received and sent"
Click OK

Without touching any other control or key press the stepper advance piston ONCE
HW will log this in its log file.
Before doing anything else using the menus go back to the screen where you ticked the box to turn on MIDI logging.
(General Settings | General Preferences| Advanced preferences and then clear the box before "diagnostics: log all Midi...."
Click OK.

This turns the midi logging off.

From the main menu select
Help then
View activity log...

This opens the activity log in a browser windon, the most recent activities (the logged midi data) will be at the bottom of the page.

You can then see the midi data sent by the stepper advance piston. There should be one message about the advance piston - if there are more then that probably means that there is problem with the advance switch or its configuration.

Re: Jumper stepper

PostPosted: Fri Nov 09, 2018 4:31 pm
by profeluisegarcia
Hello Lain:
I appreciate very much your way to provide HW instructions. Thanks
I have done the task as indicated several times and this has been the Log report:
INFO: 2520 Audio and Midi started...Audio engines option: interpolation...(no one message about advance piston).
Also, I assigned this stepper function to two different pistons, and I got the same result. I guess should be a hidden command responsible of these jumps. ¿Another idea? Thanks again.

Re: Jumper stepper

PostPosted: Fri Nov 09, 2018 6:50 pm
by profeluisegarcia
Hello Lain, me again¡
Let me update you: I installed HW conf. 3 and it did not show the problem. I went back to the original configuration(1), I configured again the pistons (which I had been doing many times before), and everything with pistons and setters started to behave correctly¡ I´m very satisfied because the problem is over, but a little upset by not knowing the cause (or perhaps because The Phantom of HW is in action¡).
Thanks for your kind assistance¡

Re: Jumper stepper

PostPosted: Fri Nov 09, 2018 7:21 pm
by IainStinson
When you turned the midi logging on you should have seen a warning from HW that you had indeed turned this on - you need to agree to continue with the logging. (If you did not see this message then logging was not actualy turned on.)

Rather than turning the midi loggin off before you browse the log file, browse the log file after pressing the piston configured to advance the stepper.

Make sure you browse to the bottom of the log file...

You should see an INF message which gives the midi information sent when you press the advanced piston.

When midi loging is enabled you may see other traffic generated by your console (all notes off messages from the keyboard for example) - ignore these.

What do you find in the log?

Remember to turn midi logging off when you've looked at the log.

Do you know what midi commands your pistons are supposed to send. It might want to check what HW has detected for your stepper advance.

On my console the pistons all send notes on/off messages.

You can see what HW has detected when you autodetect the piston by right clicking on the virtual control and selecting Adjust midi trigger settings. This url takes you to an image of my settings for an advance stepper piston. The output, input 2 and output 2 tabs should inidicate that these are disabled. Is your similar?