Search:
Submit Search


Installer crash, OSX 10.14.1

Hauptwerk software technical support only. Please make sure you have read the manual, tutorials and FAQ pages before requesting support.

Installer crash, OSX 10.14.1

Postby HolyFamilyAnchorage » Wed Dec 12, 2018 12:59 pm

Hi all, I'm having trouble installing Hauptwerk on a new Mac running the latest build of Mojave. I've installed Java and can run the installer up to the point where it says "Please wait while the installer is being configured," then it just quits with no error notification whatsoever. Install.log isn't shedding any light on the problem. Any help you can provide would be greatly appreciated.
HolyFamilyAnchorage
Member
 
Posts: 11
Joined: Sun Oct 13, 2013 6:06 pm

Re: Installer crash, OSX 10.14.1

Postby HolyFamilyAnchorage » Wed Dec 12, 2018 1:12 pm

Additionally, my dongle is not recognized by my new Mac.
HolyFamilyAnchorage
Member
 
Posts: 11
Joined: Sun Oct 13, 2013 6:06 pm

Re: Installer crash, OSX 10.14.1

Postby chr.schmitz » Wed Dec 12, 2018 2:25 pm

Hello,

You can download the very latest Sentinel HASP drivers (v7.90 -- released today) here:
https://sentinelcustomer.gemalto.com/sentineldownloads/?s=&c=End+User&p=Sentinel+HASP&o=Mac&t=all&l=all

The Hauptwerk installation probably fails, because it requires a very old Java 6 version. The installation package for Java 6 can be found here:
https://support.apple.com/kb/DL1572?viewlocale=en_US

If this still does not work (you have to start the installer a few times if it does not work directly), I have an unofficial unsupported tip for you: if you have a working system you can just copy the folders /Hauptwerk and /Applications/Hauptwerk to the new Mac.

Cheers,
Chris
User avatar
chr.schmitz
Member
 
Posts: 307
Joined: Mon Aug 26, 2013 12:49 am

Re: Installer crash, OSX 10.14.1

Postby HolyFamilyAnchorage » Wed Dec 12, 2018 3:14 pm

The legacy Java install didn’t work for me, but I was able to work around the issue by showing the installer package contents and running it from there. The first install corrupted (predictably) but the repair installation is stable.

Thank you for the updated driver link - Hauptwerk now recognizes the dongle’s existence, but not that it’s a licensed one. :/
HolyFamilyAnchorage
Member
 
Posts: 11
Joined: Sun Oct 13, 2013 6:06 pm

Re: Installer crash, OSX 10.14.1

Postby high5ths » Sat Mar 23, 2019 2:35 am

Update: I was able to solve this using the suggestion in the linked thread below to download the installer on a Windows computer and copy over to a Mac. Then the installer worked like a charm.


I had the same crash (under macOS Mojave 10.14.3), and trying to run the installer from within the package contents *appeared* to work but only installed the /Applications/Hauptwerk items, it didn't make any of the necessary folders at the root level of my HD. I'm copying over folders from my backup install, but is there a trick to making the installer work? I'm trying for a super clean, brand new Hauptwerk install...

I already installed the Sentinel HASP drivers from downloadhauptwerk.com and ran the Java 6 installer as well, so that's not it.

I found this thread from 2016 documenting some installer issues and possible solutions — is that still what is happening now? I will try some of the suggestions in that thread tomorrow.

Thanks,
Jeff
high5ths
Member
 
Posts: 14
Joined: Wed May 08, 2013 12:42 am
Location: New York City


Return to Technical support

Who is online

Users browsing this forum: No registered users and 1 guest