Search:
Submit Search


CPU Problems

Hauptwerk software technical support only. Please make sure you have read the manual, tutorials and FAQ pages before requesting support.

CPU Problems

Postby münsterorganist » Thu Mar 28, 2019 2:09 pm

Last year I have got a new PC with windows 10 Prof.64 Bit. All was good. Then I have connected the PC to Ethernet , for downloading. The same time windows has updated himself. And now the CPU in the audio window and the sound goes terrible to the red area . I didn't found the mistake, and so I installed Windows complete new without updates. I have tried it two times, ever the same. After window update all was unstable. So I disconnected Ethernet.
Do anywhere have the same Problem and can give a Solution?
münsterorganist
Member
 
Posts: 13
Joined: Sat Aug 27, 2016 3:24 am

Re: CPU Problems

Postby IainStinson » Fri Mar 29, 2019 7:06 am

Have you tried disabling the system service Sysmain in your configuration of Windows 10?
This service used to be called Superfetch. It is not required for HW and can cause excessive cpu usage.
Disconnect the Ethernet connection and disable any wireless (WiFi) interfaces you have.
Does this improve the audio?
Iain
Last edited by IainStinson on Fri Mar 29, 2019 8:35 am, edited 1 time in total.
User avatar
IainStinson
Member
 
Posts: 782
Joined: Tue Dec 29, 2009 7:08 pm
Location: NW England, UK

Re: CPU Problems

Postby engrssc » Fri Mar 29, 2019 8:17 am

User avatar
engrssc
Member
 
Posts: 5926
Joined: Mon Aug 22, 2005 11:12 pm
Location: Roscoe, IL, USA

Re: CPU Problems

Postby münsterorganist » Fri Mar 29, 2019 1:03 pm

Thank you for your answer. No I didn't do it. Normally I don't have any connection to Ethernet. But after updating Windows by itself I disconnected the Ethernet. But the CPU runs in the red region and sounds device falter. With the older edition windows 10 which I have installed again all is good without problems. I fear, if Windows Update runs again, I will have the same problems. And every time reinstalling my Sample Sets again, it's need a lot of time.
münsterorganist
Member
 
Posts: 13
Joined: Sat Aug 27, 2016 3:24 am

Re: CPU Problems

Postby engrssc » Fri Mar 29, 2019 1:18 pm

Did you do what Iain suggested?
I provided a link telling you how to do it.

Rgds,
Ed
User avatar
engrssc
Member
 
Posts: 5926
Joined: Mon Aug 22, 2005 11:12 pm
Location: Roscoe, IL, USA

Re: CPU Problems

Postby münsterorganist » Fri Mar 29, 2019 1:38 pm

Dear Ed, I just red it and I' try it this weekend.
Best regards
münsterorganist
Member
 
Posts: 13
Joined: Sat Aug 27, 2016 3:24 am

Re: CPU Problems

Postby münsterorganist » Sat Mar 30, 2019 7:19 am

I just have done it. Really I have an old version of Windows. There is superfetch installed. I have deactivated the entry. Current situation is stable. Thank you for help.
münsterorganist
Member
 
Posts: 13
Joined: Sat Aug 27, 2016 3:24 am

Re: CPU Problems

Postby Rimokatolik » Tue Apr 23, 2019 11:35 pm

Wow! I must say thank you. I could not believe it. I have HP Z800 with 24 cores (actually 12 + HT), and I never liked other advises that are usually given as I am using this computer for other things besides HW (sw development, relational db, ...) and even though my CPU % is < 10% HW CPU monitor would pretty often go into red. After I disabled SysMain it is in only 2 green bars range.

THANK YOU! THANK YOU! THANK YOU! THANK YOU!
Rimokatolik
Member
 
Posts: 34
Joined: Sat Dec 03, 2016 1:40 am

Re: CPU Problems

Postby nrorganist » Tue Jul 02, 2019 9:27 am

If you are interested in a Windows Update transition from a Windows 10 SuperFetch version to a SysMain version, read on.

On my prototype Hauptwerk system with a quad core i7-4771 and 32GB of memory, I have been running Windows 10 Pro Version 1709 with Superfetch disabled for more than a year. Periodically, I have executed Windows Updates to receive the intervening patches on top of Version 1709. With my largest sample set loaded, I have more than 6GB of memory free. Since I also use this PC for non-Hauptwerk software, it is always connected to the Internet.

Yesterday, Windows kindly announced that Version 1709 for Pro had reached End of Service. This can be verified by looking at: https://docs.microsoft.com/en-us/windows/release-information/.

Also during the past several weeks, I have noticed the audio output at times has had periodic clicking sounds and very short audio drops (roughly every 5-10 seconds). This has occurred even while playing a single rank on a manual and the Hauptwerk meter never leaving the green zone. This has some similarities to what several folks have previously reported many times.

I decided to update to the latest Version in the Semi-Annual Channel: Windows 10 Pro Version 1903, which first became available on May 21, 2019. The update process was successful, but lasted long enough (most of an hour to possibly more than an hour) that I didn't watch or time it.

Others have mentioned that in new Windows 10 Versions, Superfetch has been replaced by SysMain. I thought when updating from a "Superfetch" version to a "SysMain" version, there might be the possibility that the Disabled Superfetch setting might be carried over to SysMain's setting.

After my update, I checked Version 1903 and SysMain was Enabled. I had to manually disable SysMain using instructions Ed previously posted - https://www.techosaurusrex.com/windows-10-sysmain-causing-high-disk-or-high-cpu-usage-heres-how-to-disable-it/

After SysMain was disabled, in more than an hour's worth of playing registrations from a single rank to Tutti on a 7+GB sample set, I have not encountered any periodic clicking sounds or audio drops. For me, this single setting change appears to have eliminated my Hauptwerk audio interruptions on what I would consider a fairly lightly loaded PC system.

Mark
User avatar
nrorganist
Member
 
Posts: 32
Joined: Mon Sep 26, 2016 7:22 pm
Location: Northern Colorado, USA


Return to Technical support

Who is online

Users browsing this forum: No registered users and 3 guests