It is currently Mon Mar 30, 2020 1:08 pm


Losing MIDI Settings

Hauptwerk software technical support only. Please make sure you have read the manual, tutorials and FAQ pages before requesting support.
  • Author
  • Message
Offline

OrganoPleno

Member

  • Posts: 578
  • Joined: Thu Dec 03, 2009 5:08 pm

Losing MIDI Settings

PostMon Dec 16, 2019 11:54 pm

Hello! I have noticed that on my System, whether running HW-4 or HW-V, the MIDI settings appear to be rather vulnerable. With an Organ loaded, then under "general settings/midi ports", if I uncheck my primary port (regardless of whether other ports are checked or not), of course I get no console input because that's where it's coming from. If I then check my primary MIDI port once again as "input"... the system works EXCEPT that all of my MIDI settings for that Organ have vanished! Once again I need to auto-recognize all of the keyboards, console pistons, etc.

Is this known and normal behaviour? Or is my System doing something unusual here... which might relate to why I cannot get any MIDI settings to carry forward from HW-4 to HW-V by any means tested so far?
Offline
User avatar

mdyde

Moderator

  • Posts: 11803
  • Joined: Fri Mar 14, 2003 2:19 pm
  • Location: UK

Re: Losing MIDI Settings

PostTue Dec 17, 2019 6:33 am

Hello OrganoPleno,

Yes -- that's the expected behaviour. If auto-detecting MIDI settings, Hauptwerk (v4 or v5) also detects the MIDI port through which they were heard, so as to allow for people (probably the majority) who have more than one MIDI device using a given MIDI channel. If you then disable (untick) a MIDI port, any MIDI settings that used it will automatically be cleared (since migrating them automatically to any other MIDI port might not be what the person wanted, and could give unexpected results).

If you only have, and will only ever have, a single MIDI port being used with Hauptwerk at a time, or if you have multiple MIDI ports but you're absolutely certain that all of your MIDI devices use (and always will use) distinct MIDI channels, then you can manually change all of the MIDI port settings for the auto-detected MIDI settings (e.g. via the 'Organ setting | Stop/coupler/tremulant switches and pistons/buttons' screen) to '<Any enabled port>'. If set specifically to that value, then the settings won't be cleared even if you disable (untick) any given MIDI port.
Best regards, Martin.
Hauptwerk software designer/developer, Milan Digital Audio.

[Please use email or the Contact page if you need to contact us privately, rather than private forum messages.]
Offline

mnailor

Member

  • Posts: 658
  • Joined: Sat Nov 30, 2013 6:57 pm
  • Location: Atlanta, GA

Re: Losing MIDI Settings

PostTue Dec 17, 2019 10:09 am

Martin, if I change every organ's MIDI settings to <Any enabled port>, will that protect against loss of MIDI settings when Windows decides my MIDI inputs should be renamed or I want to move them to a different USB port? Or is there a better way to prevent that?

(All my MIDI controllers are on distinct channels.)

Thank you.
Offline
User avatar

mdyde

Moderator

  • Posts: 11803
  • Joined: Fri Mar 14, 2003 2:19 pm
  • Location: UK

Re: Losing MIDI Settings

PostTue Dec 17, 2019 10:23 am

Hello nmailor,

mnailor wrote:Martin, if I change every organ's MIDI settings to <Any enabled port>, will that protect against loss of MIDI settings when Windows decides my MIDI inputs should be renamed or I want to move them to a different USB port? Or is there a better way to prevent that?

(All my MIDI controllers are on distinct channels.)


Yes -- provided all devices use distinct MIDI channels then that's safe, and is the only way currently to guard against the operating system changing MIDI port names. (We do have enhancement requests logged to make Hauptwerk's auto-detection default to '<Any enabled port>', and for MIDI port migration wizards, etc.)
Best regards, Martin.
Hauptwerk software designer/developer, Milan Digital Audio.

[Please use email or the Contact page if you need to contact us privately, rather than private forum messages.]

Return to Technical support

Who is online

Users browsing this forum: No registered users and 6 guests