It is currently Sat Jan 23, 2021 9:21 am


installer problems

Hauptwerk software technical support only. Please make sure you have read the manual, tutorials and FAQ pages before requesting support.
  • Author
  • Message
Offline

fermata

Member

  • Posts: 123
  • Joined: Tue Aug 16, 2016 2:42 pm

installer problems

PostWed Dec 23, 2020 1:25 pm

Hello.
I have Big Sur on a 16" MacBook Pro with 32GB of memory. The Hauptwerk installer does not work for me. (Haven't used Hauptwerk in a long while -- not on this new computer.) I keep getting the 0657 message when trying to open Hauptwerk after downloading the installer. Any ideas what is wrong?
Thanks for any help.
Offline
User avatar

mdyde

Moderator

  • Posts: 12885
  • Joined: Fri Mar 14, 2003 1:19 pm
  • Location: UK

Re: installer problems

PostWed Dec 23, 2020 3:52 pm

Hello fermata,

(For our reference, error 0057 is "Could not create the folder ...", which will probably be due to a file/folder permissions issue.)

Did you have any version at all of Hauptwerk installed on this computer prior to running the v6.0.1 installer? Which version, if so? Was it running successfully on this Mac under macOS 11 ('Big Sur')?

If you didn't previously have Hauptwerk installed on this Mac, when you set the Mac up, did you use macOS' function to transfer your settings and programs from another Mac? (Doing so can result in a partial/broken Hauptwerk installation.)
Best regards, Martin.
Hauptwerk software designer/developer, Milan Digital Audio.
Offline

fermata

Member

  • Posts: 123
  • Joined: Tue Aug 16, 2016 2:42 pm

Re: installer problems

PostFri Dec 25, 2020 9:19 am

I never installed Hauptwerk on this computer. I am afraid i will have to start from scratch. I have a key from Hauptwerk IV. That's it. Do I need to upgrade to Hauptwerk VI? Will Hauptwerk IV no longer work? Is there no longer an installer for Hauptwerk IV? I thought I found one online, but cannot find it anymore. ...
Offline
User avatar

ldeutsch

Member

  • Posts: 507
  • Joined: Tue Mar 04, 2008 12:02 pm
  • Location: Chatsworth, California, USA

Re: installer problems

PostFri Dec 25, 2020 10:59 am

I cannot help with your question about the Hauptwerk Installer, but I can at least verify that it is possible to put HW 4 on a Mac (and I assume also on a Windows machine) without the installer. I had to do this on a laptop I own that runs Catalina. In addition to my two organ consoles that each have their own HW VI dedicated computer, I use my laptop to develop new HW sample sets - even when I am on travel (which is not often this year!) HW IV has the advantage that you can run the advanced edition in trial mode and the only artifact of doing so is the bell that rings every few seconds while organs are playing. I can do this without a dongle and without Internet connectivity - something HW VI cannot do.

If you have another computer that has still has a working copy of HW 4, you can copy all the files to your new machine. However, you cannot place the HW data files (everything that is in /Hauptwerk) in the same place. Beginning with Catalina, user data files can no longer be stored in this way. Instead, you have to create a new folder for these in your user area on the computer - HW new places these in /your_username/Hauptwerk. Also, you will need to edit one text file,

/Hauptwerk/InternalResources/FileLocations.FileLocations_Hauptwerk_xml

so that HW knows where you placed your data folder.

You might also have to change some file or folder permissions depending on your installation. I cannot tell you which ones as this appears to be highly variable depending on how your computer is configured.

This kind of thing is not for people who have limited software skills - but it is certainly possible. Of course you will be on your own because HW 4 is no longer supported.

If you do not have a need for this as an extra installation, I recommend upgrading to HW VI. HW VI is a much-improved product over HW 4 and I believe our community should be supporting development of HW through our upgrade purchases.

Les
Offline
User avatar

mdyde

Moderator

  • Posts: 12885
  • Joined: Fri Mar 14, 2003 1:19 pm
  • Location: UK

Re: installer problems

PostFri Dec 25, 2020 11:03 am

Hello fermata,

Don't worry -- there's no need to install v4, or benefit in installing it, and it wouldn't install anyway on recent macOS versions. My guess, based on the error message you were getting, is that on this Mac you'd previously used macOS' built-in function to transfer programs and settings from another Mac that had v4 on it, which would result in that error (especially since v4 wasn't compatible with macOS 10.15 or later).

Please try following steps 2 onwards in this topic, which cover how to remove a partial/broken v4 installation, being especially careful to make sure that *all* of the folders in step 3 are completely deleted using Finder, then re-install v6:

viewtopic.php?f=10&t=17850

mdyde wrote:VERY IMPORTANT: In order to ensure that those situations don't result in a broken Hauptwerk v5+ installation:
...
    2. If you're able to launch your currently-installed version of Hauptwerk's uninstaller (which can be found in the '/Applications/Hauptwerk Virtual Pipe Organ/Uninstaller' folder), then use that uninstaller to uninstall Hauptwerk completely, selecting the option in the uninstaller to remove all files and settings.

    3. Use Finder to make sure that all of the following folders are completely deleted (if they exist). You may be prompted for your password:

      '/Applications/Hauptwerk Virtual Pipe Organ'
      '/Users/Shared/Relocated Items/Hauptwerk'
      '/Hauptwerk'

    [The latter folder is at the very top-level of your computer's SSD/hard-drive. In order to be able to find it, make sure that the 'Sidebar | Devices | Hard disks' option is ticked in Finder's preferences.]



Also delete this folder:

'/Users/<your-macOS-username>/Hauptwerk'

mdyde wrote:Finally:

    4. Run the Hauptwerk [v6.0.1] installer to perform a clean installation of Hauptwerk, using its current (10.15-safe) default locations (or choose custom locations that are not on the Mac's internal drive). (If you're using macOS 10.15, in order to launch the Hauptwerk v5 installer you need to right-click on it, then select 'Open'.)

    5. You can then [optionally] use 'File | Restore ...' in Hauptwerk v5+ to get your previous Hauptwerk settings/combinations/voicing back [from a Hauptwerk settings backup, if you have one].
    ...
    6. Use 'File | Install ...' in Hauptwerk [v6.0.1] to install the current versions of any sample sets that you might have (making sure that you install v5-compatible versions if applicable).


Does that solve it?
Best regards, Martin.
Hauptwerk software designer/developer, Milan Digital Audio.
Offline
User avatar

mdyde

Moderator

  • Posts: 12885
  • Joined: Fri Mar 14, 2003 1:19 pm
  • Location: UK

Re: installer problems

PostFri Dec 25, 2020 11:08 am

P.S. I see Les and I replied at the same time.

Re-reading your post, I'm not clear whether you mean that you have a licence for Hauptwerk v6/v5, or only a licence for v4?

If only v4, then v4 isn't natively compatible with macOS 10.15 or macOS 11 ('Big Sur') and won't install on it. The only way possibly to get it to work would be to try to 'hack' it as Les described, but we can't officially help with that, I'm afraid, and v4 is no longer available or officially supported -- sorry.
Best regards, Martin.
Hauptwerk software designer/developer, Milan Digital Audio.
Offline

fermata

Member

  • Posts: 123
  • Joined: Tue Aug 16, 2016 2:42 pm

Re: installer problems

PostSat Jan 09, 2021 8:37 am

Dear Les and Martin,
Thank you :D both for your helpful replies. I followed the advice to simply upgrade to v6. I ended by having to comb through my computer and delete all HW folders (you surmised correctly, Martin, that whatever I had on this computer had been automatically transferred from a former computer). I am up and running v6 with wonderful help from Hauptwerk Support. The user guide is...rather monstrous to tackle (it's GROWN since I last looked at it) and not always understandable. So thank goodness for HW Support and this Forum! And thanks again to you both! :D
Offline
User avatar

mdyde

Moderator

  • Posts: 12885
  • Joined: Fri Mar 14, 2003 1:19 pm
  • Location: UK

Re: installer problems

PostSat Jan 09, 2021 8:40 am

Thanks very much, fermata.

Glad to hear you're up and running again, and hope you enjoy the new version.
Best regards, Martin.
Hauptwerk software designer/developer, Milan Digital Audio.

Return to Technical support

Who is online

Users browsing this forum: Theorbe and 9 guests