It is currently Thu Jan 28, 2021 3:37 am


Mac hardware requirements for Hauptwerk v6

Hauptwerk software technical support only. Please make sure you have read the manual, tutorials and FAQ pages before requesting support.
  • Author
  • Message
Offline

Antoni Scott

Member

  • Posts: 841
  • Joined: Fri Sep 24, 2004 5:18 pm

Mac hardware requirements for Hauptwerk v6

PostSun Dec 27, 2020 6:20 am

Hello Martin Dyde:
I have been reading the comments about Version 6 and have a few questions about the capabilities of my computer to handle the new software update. If I read correctly, there is a greater processing requirement that is needed to operate the Version 6 software. I have a "Vintage" 2010 MacPro 12-core (3.33ghz) with 96 GB RAM and was wondering if these are the only hardware requirements to handle the new upgrade. I use the 12-core ( with Version 5) all the time but also have an original dual-quad core from 2007 with 32 GB RAM as a back-up. As technology moves forward so does the need to keep up with it with more and more powerful computers so I was wondering if both my vintage Mac-Pro's will work with the new Version 6.
Antoni Scott
Offline
User avatar

mdyde

Moderator

  • Posts: 12908
  • Joined: Fri Mar 14, 2003 1:19 pm
  • Location: UK

Re: Mac hardware requirements for Hauptwerk v6

PostSun Dec 27, 2020 6:47 am

Hello Antoni,

[I've split your post off to this new topic.]

Thanks very much for the interest in v6.

The supported hardware and software platforms for v6 are exactly the same as they were for v5:

https://www.hauptwerk.com/wp-content/up ... isites.pdf

... so if any given computer could run v5 successfully, then it should also be able to run v6.

I see that Apple list 'mid-2010' Mac Pros are the earliest models that can run macOS 10.13 ('High Sierra'), which is the earliest macOS version that's officially supported for Hauptwerk v5/v6:

https://support.apple.com/kb/SP765?locale=en_US

Hence if you currently have Hauptwerk v5 running on it, then you should be able to run v6 on it.

(You might possibly be able to get Hauptwerk v5/v6 to work on macOS 10.11 or 10.12, but they aren't officially supported. Your 2007 Mac Pro definitely wouldn't be able to run any version of macOS that could work with Hauptwerk v5/v6, since macOS 10.11 can't run on it: https://support.apple.com/kb/SP728?locale=en_US .)

Antoni Scott wrote:If I read correctly, there is a greater processing requirement that is needed to operate the Version 6 software.


Any computer that could run v5 should be able to run v6.

There are two very CPU-intensive options in Hauptwerk v6 which give better audio quality ('High-definition pitch-shifting' and 96 kHz). If you enable both options then any given computer will probably be able to manage about 25% of the polyphony that it would in v5 (or in v6 if neither option is enabled).

However, they are simply options -- you don't have to enable them, and if you don't have them enabled then v6 should perform as well on any given computer as v5 did. A 12-core Mac Pro would have lots of computing power, so you might well find it ample for enabling one or both of the new audio quality options anyway.

Hope that helps.
Best regards, Martin.
Hauptwerk software designer/developer, Milan Digital Audio.

Return to Technical support

Who is online

Users browsing this forum: No registered users and 16 guests