Search:
Submit Search


HW4 & Launchpad Button LEDs

Hauptwerk software technical support only. Please make sure you have read the manual, tutorials and FAQ pages before requesting support.

HW4 & Launchpad Button LEDs

Postby kiwiplant » Sat Apr 23, 2011 4:41 pm

Does anyone know how to set the state of Launchpad LEDs (color and intensity) used for stop tabs from HW4 ?

(working from recollection of how it was in HW3)
This used to be possible in HW3 using the General MIDI settings to output different MIDI messages for switch ON/OFF states. These settings were not possible for each organ individually.

Now in HW4 with the settings per organ, this should be better, but it seems to have less ability to set the ON//OFF messages. Maybe I just don't know how to do it now?

Anyone else having this problem or know how to get it working again?

Thanks,
Paul
User avatar
kiwiplant
Member
 
Posts: 286
Joined: Fri Dec 05, 2008 6:40 am
Location: Ohio, USA

Re: HW4 & Launchpad Button LEDs

Postby mdyde » Sat Apr 23, 2011 4:52 pm

Hello Paul,

Another Hauptwerk user contacted us today to explain the particular MIDI implementation that the Novation Launchpad uses to control the colour and intensity of its LEDs. We'll look into adding support for that in Hauptwerk. (We'd want to make sure that it's implemented completely natively, without requiring any technical/MIDI expertise on the part of the user.)

Hence we're now aware of that and will be looking into it.
Best regards,
Martin.

[Please use email or the Contact page if you need to contact us privately, rather than private forum messages.]

Image
User avatar
mdyde
Moderator
 
Posts: 10191
Joined: Fri Mar 14, 2003 2:19 pm
Location: UK

Re: HW4 & Launchpad Button LEDs

Postby kiwiplant » Sat Apr 23, 2011 5:35 pm

Martin,

Great news, Thanks !

Here is a programmers ref doc PDF for it.
http://www.novationmusic.com/support/launchpad/

It is possible to use the 8 round buttons on the top with color changes too even though the programmers reference pictures don't show much about them. They output control change messages instead of note on/off.

Here are a couple interesting examples of similar buttons on Estey Theatre Organs. So maybe not so weird to be using Launchpads for stop controls now. :D

Image

Image

Paul
User avatar
kiwiplant
Member
 
Posts: 286
Joined: Fri Dec 05, 2008 6:40 am
Location: Ohio, USA

Re: HW4 & Launchpad Button LEDs

Postby mdyde » Sun Apr 24, 2011 7:10 am

Thanks, Paul.

We'll see what we can do.
Best regards,
Martin.

[Please use email or the Contact page if you need to contact us privately, rather than private forum messages.]

Image
User avatar
mdyde
Moderator
 
Posts: 10191
Joined: Fri Mar 14, 2003 2:19 pm
Location: UK

Re: HW4 & Launchpad Button LEDs

Postby AEK » Thu Jun 02, 2011 4:31 pm

Hello Martin!
Is there any news on the issue of setting LEDs LaunchPad?
User avatar
AEK
Member
 
Posts: 72
Joined: Mon May 23, 2011 5:58 am
Location: Russia, Moscow

Re: HW4 & Launchpad Button LEDs

Postby kiwiplant » Thu Jun 02, 2011 6:06 pm

Martin,

If you need any testers for the launchpad stuff, I'm able to help. 3 of them here.

Paul
User avatar
kiwiplant
Member
 
Posts: 286
Joined: Fri Dec 05, 2008 6:40 am
Location: Ohio, USA

Re: HW4 & Launchpad Button LEDs

Postby G3 » Thu Jun 02, 2011 6:32 pm

Me too! I have two and thinking about two more.

George (G3)
Owner/Builder of Hammond-Hauptwerks X-66 3-manual organ.
User avatar
G3
Member
 
Posts: 276
Joined: Mon Jul 03, 2006 12:04 pm
Location: Richland Center, WI

Re: HW4 & Launchpad Button LEDs

Postby mdyde » Fri Jun 03, 2011 7:00 am

Hello AEK/Paul/George,

Sorry - I haven't been able to get to this yet, but it's in the queue and is a very high priority. I am doing everything I can to get through the backlog of issues that people need me to look at it.

We'll add support for the Launchpad's LEDs as soon as we possibly can, include that change in Hauptwerk v4.0.1, and contact those people who have Launchpads to send a temporary patch to them in them meantime, as soon as the change is done.

Hence please just be a little patient for now and we'll get a fix to you as soon as possible. Sorry again for the problem.
Best regards,
Martin.

[Please use email or the Contact page if you need to contact us privately, rather than private forum messages.]

Image
User avatar
mdyde
Moderator
 
Posts: 10191
Joined: Fri Mar 14, 2003 2:19 pm
Location: UK

Re: HW4 & Launchpad Button LEDs

Postby AEK » Fri Jun 03, 2011 9:02 am

Thank Martin.
In looking forward Update HW 4.01
User avatar
AEK
Member
 
Posts: 72
Joined: Mon May 23, 2011 5:58 am
Location: Russia, Moscow

Re: HW4 & Launchpad Button LEDs

Postby Diz88 » Fri Jun 03, 2011 7:00 pm

and contact those people who have Launchpads to send a temporary patch to them in them meantime, as soon as the change is done.


Thanks Martin,

Please include me on the list for the Launchpad temporary patch.
I have two of them - and once things get straightened out, will get more.

Dave in Homer City, PA
Diz88
Member
 
Posts: 1
Joined: Fri May 28, 2010 10:08 am

Re: HW4 & Launchpad Button LEDs

Postby mdyde » Sat Jun 04, 2011 7:01 am

Thanks, Dave. Will do.
Best regards,
Martin.

[Please use email or the Contact page if you need to contact us privately, rather than private forum messages.]

Image
User avatar
mdyde
Moderator
 
Posts: 10191
Joined: Fri Mar 14, 2003 2:19 pm
Location: UK

Re: HW4 & Launchpad Button LEDs

Postby mdyde » Sun Jun 12, 2011 12:07 pm

A quick update:

I've finished implementing full, native support for the Novation Launchpad implementation (including auto-detection, full automatic control of LED colour, both its types of buttons, and support for multiple Launchpad units) and am in the final stages of testing it.

However, I currently only have one Launchpad and I needed to include quite a lot of complex code for seamless support of multiple Launchpads, which relies in part on the names that the Launchpad USB-MIDI driver uses (so that Hauptwerk can know how to associate incoming and outgoing events with the correct Launchpads).

Just to check that I have it right, would somebody who has more than one Launchpad attached to their computer mind emailing us a diagnostic file ('Help | Create a diagnostic file ...'), which will allow me to see the port names the driver is using?

Also if there is a Launchpad user using a language version of Windows other than English, it would be helpful to have a diagnostic file from them too.

Assuming my assumptions prove to be correct, I hope to be able to get a temporary build to you all in the next day or two with the new Launchpad support.

Many thanks.
Best regards,
Martin.

[Please use email or the Contact page if you need to contact us privately, rather than private forum messages.]

Image
User avatar
mdyde
Moderator
 
Posts: 10191
Joined: Fri Mar 14, 2003 2:19 pm
Location: UK

Re: HW4 & Launchpad Button LEDs

Postby IainStinson » Sun Jun 12, 2011 1:05 pm

Martin,
On Windows if you unplug and the device and attachit to a different USB port, Windows assumes it is a second device and changes the final digit from "1" to "2". I noticed this when I was installing the device from a rear USB port (with a longer cable). This might be of some help. (I only have one LaunchPad.)
Iain
User avatar
IainStinson
Member
 
Posts: 513
Joined: Tue Dec 29, 2009 7:08 pm
Location: NW England, UK

Re: HW4 & Launchpad Button LEDs

Postby kiwiplant » Sun Jun 12, 2011 1:19 pm

Mine are named "Launchpad 1" "Launchpad 2"... in OS X's "MIDI Studio" window.
That way they are not tied to certain manuals worth of tabs and I can use them with different theatre organs.

Paul
User avatar
kiwiplant
Member
 
Posts: 286
Joined: Fri Dec 05, 2008 6:40 am
Location: Ohio, USA

Re: HW4 & Launchpad Button LEDs

Postby mdyde » Sun Jun 12, 2011 1:38 pm

Thanks, Iain/Paul.

That's looks like my implementation should be fine then.
Best regards,
Martin.

[Please use email or the Contact page if you need to contact us privately, rather than private forum messages.]

Image
User avatar
mdyde
Moderator
 
Posts: 10191
Joined: Fri Mar 14, 2003 2:19 pm
Location: UK

Next

Return to Technical support

Who is online

Users browsing this forum: anco111 and 1 guest