It is currently Wed Dec 11, 2019 8:22 am


Curious Audio Glitch

Speakers, amplifiers, headphones, multi-channel audio, reverb units, mixers, wiring, ...
  • Author
  • Message
Offline
User avatar

Stuart

Member

  • Posts: 13
  • Joined: Sun Oct 10, 2010 1:02 pm

Curious Audio Glitch

PostSat Apr 13, 2019 5:15 pm

Ever since my last Windows 10 update (which I didn't intend to happen!) I've been having problems with audio glitches in spite of checking most of the usual Windows settings...still working on that. But, the curious thing is that I have also been recording a mix-down of three stereo channels and surprisingly the audio glitches do not show up in the recordings. Does anyone know what might cause this to happen? I'm glad it does while I'm trying to deal with the glitches that are heard through the speakers, but found this to be totally unexpected.

The audio unit is a USB M-Audio 8-Track with 3 stereo channels, and 1 stereo channel used as the mix-down.
Offline
User avatar

Tweedle_Dee

Member

  • Posts: 147
  • Joined: Tue Oct 15, 2013 11:58 pm
  • Location: Rainy side of Oregon

Re: Curious Audio Glitch

PostSat Apr 13, 2019 5:55 pm

Same problem here. Last (unintentional!) update started glitches where I never had them before. Yes, superfetch is disabled. Been too busy to look into very much yet. Sorry, I can't help, but just wanted to say I'm experiencing the same thing. Interface is a MOTU Mk4 Ultralite.
Offline
User avatar

IainStinson

Member

  • Posts: 867
  • Joined: Tue Dec 29, 2009 7:08 pm
  • Location: NW England, UK

Re: Curious Audio Glitch

PostSat Apr 13, 2019 7:19 pm

Have a look at http://forum.hauptwerk.com/viewtopic.php?f=4&t=17436
This might have some ideas which could help.
Iain
Offline
User avatar

engrssc

Member

  • Posts: 6157
  • Joined: Mon Aug 22, 2005 11:12 pm
  • Location: Roscoe, IL, USA

Re: Curious Audio Glitch

PostSun Apr 14, 2019 9:46 am

Tweedle_Dee wrote:Interface is a MOTU Mk4 Ultralite.


The latest (Windows) MOTU Pro Audio Installer (Release Date 2019-03-21) from MOTU is here:

http://motu.com/techsupport/technotes/driverlog Go down near the bottom of the list for UltraLite-mk4

Don't know if that would do anything for the glitches. IMO the MOTU Mk4 Ultralite is an excellent audio box. 8)

BTW, I notice MOTU site comes up as Not Secure, referring to a thread (again) discussing that situation with the HW Forum.

http://forum.hauptwerk.com/viewtopic.php?f=1&t=17481

Rgds,
Ed]
Offline
User avatar

Tweedle_Dee

Member

  • Posts: 147
  • Joined: Tue Oct 15, 2013 11:58 pm
  • Location: Rainy side of Oregon

Re: Curious Audio Glitch

PostMon Apr 15, 2019 2:40 pm

Thanks. I probably don't have the very latest driver/firmware then. After Easter I'll try it...
Offline
User avatar

dhm

Member

  • Posts: 1091
  • Joined: Thu Jan 12, 2006 11:50 am
  • Location: Rochester, UK

Re: Curious Audio Glitch

PostTue Apr 16, 2019 3:36 am

I'm fairly sure this won't be an audio device driver problem.
Search the Forum and you'll see that large numbers of people have had problems with audio glitches in Windows 10, even when stripped down to a "bare-bones" state.
Something in Win 10 is causing intermittent CPU spikes.
One interesting thing I have noticed is that I *don't* get glitches on PCs which started life with Win 7 and then took the free upgrade to Win 10 a couple of years ago.
Until a fix can be found for this problem I'm reverting to using Win 7 for all the HW PCs I build in the foreseeable future. (Yes, I know M$ are withdrawing support in January 2020, but if these PCs are never connected to the Internet, that shouldn't be a problem.)
Douglas Henn-Macrae
Authorized Hauptwerk Reseller
http://www.midi-organs.eu / http://www.gundulf.org.uk
Offline
User avatar

Tweedle_Dee

Member

  • Posts: 147
  • Joined: Tue Oct 15, 2013 11:58 pm
  • Location: Rainy side of Oregon

Re: Curious Audio Glitch

PostTue Apr 16, 2019 12:21 pm

Okay, well my thinking was that if the latest version of Windows 10 introduced something that caused me and others glitches this latest go-around, maybe MOTU fixed a weakness in their driver. Probably naive to think they would react that quickly...
Offline

murph

Member

  • Posts: 600
  • Joined: Fri Mar 02, 2012 6:45 pm

Re: Curious Audio Glitch

PostTue Apr 16, 2019 12:40 pm

I'm currently having video playback issues with win10 (again). Happened a few months ago, got fixed with an emergency hotfix, now is happening again but no fix yet. Some video plays or streams, some updates every second or so, some doesn't.
This could be a similar thing......
(The HW computer is win7, offline).
Offline
User avatar

engrssc

Member

  • Posts: 6157
  • Joined: Mon Aug 22, 2005 11:12 pm
  • Location: Roscoe, IL, USA

Re: Curious Audio Glitch

PostTue Apr 16, 2019 12:58 pm

murph wrote:(The HW computer is win7, offline).


Here, too. Have several working.

Rgds,
Ed
Offline

seh52

Member

  • Posts: 203
  • Joined: Sun Jun 06, 2010 11:16 am
  • Location: Los Angeles, CA 90019

Re: Curious Audio Glitch

PostWed May 15, 2019 11:49 am

My M-Audio Firewire 410 8-channel system developed audio glitches after a Windows 10 update, too. I hired an HW expert who couldn't fix it, and suggested that my M-Audio driver may no longer be supported.

A computer tech friend showed me how to change priority from Normal to Realtime in the Task Manager and that stopped the glitches.

Here is a YouTube showing how: https://www.youtube.com/watch?v=U-PTZqjZSRk
I get there in different order, by first selecting the Details section, then the Hauptwerk program, then Right clicking on it to set priority at Realtime.

I just found a free program, Prio, that I may use to save the Realtime priority setting, so I don't have to reset it every time I open Hauptwerk. https://www.prnwatch.com/prio/
Offline
User avatar

David Baldwin

Member

  • Posts: 250
  • Joined: Sun Nov 12, 2006 1:08 pm
  • Location: Ross-on-Wye, Herefordshire, UK

Re: Curious Audio Glitch

PostThu May 16, 2019 4:30 am

I worked my way through a whole host of things after the previous win 10 upgrade. After the last one it was back to lots of glitches again. Some of my previous changes had been reversed but I was still left with one occurring about every 1-2 minutes. I discovered that sysmain was still running after I stopped it. This time I disabled it and I am now glitch free.
I think it is necessary to turn off all energy saving features. Keep the disks running and all cores active.
(Dr.) David G. Baldwin
Offline

chrisdfrith

Member

  • Posts: 38
  • Joined: Fri May 24, 2013 10:22 pm
  • Location: Mesa, AZ

Re: Curious Audio Glitch

PostFri Aug 02, 2019 1:49 pm

I found after my last Windows 10 updates were applied that SysMain was re-enabled and the audio glitches reappeared. I didn't realize some Microsoft updates could make such a change, but it seems it did. Once SysMain was disabled again, I'm glitch free once again.
Offline

seh52

Member

  • Posts: 203
  • Joined: Sun Jun 06, 2010 11:16 am
  • Location: Los Angeles, CA 90019

Re: Curious Audio Glitch

PostFri Aug 02, 2019 2:02 pm

Update and question:

The Prio program doesn't work to keep a Realtime processor setting.

How do you disable SysMain?

Thanks!
Offline
User avatar

engrssc

Member

  • Posts: 6157
  • Joined: Mon Aug 22, 2005 11:12 pm
  • Location: Roscoe, IL, USA

Re: Curious Audio Glitch

PostFri Aug 02, 2019 2:15 pm

I find on my online Win 10 computer with the latest update,there many so called new not asked for "features" :o that most likely are not HW friendly. You can Google for ways to remove them.

Rgds,
Ed
Offline

evertjan

Member

  • Posts: 226
  • Joined: Fri Dec 10, 2010 1:46 pm

Re: Curious Audio Glitch

PostFri Aug 02, 2019 3:49 pm

Windows key + R
Type in: services.msc
Search for sysmain
Double click on it and switch it to 'disable'
Also stop the service by pushing the Stop button. Not necessary because after next restart it cannot start because you disable it.

And do it again after next Windows update because Microsoft turns it on again.
Next

Return to Amplification

Who is online

Users browsing this forum: No registered users and 0 guests