It is currently Sat Jun 19, 2021 10:57 pm


Parsing Problem whilst Transferring to New PC

Hauptwerk software technical support only. Please make sure you have read the manual, tutorials and FAQ pages before requesting support.
  • Author
  • Message
Offline
User avatar

David Baldwin

Member

  • Posts: 298
  • Joined: Sun Nov 12, 2006 12:08 pm
  • Location: Ross-on-Wye, Herefordshire, UK

Parsing Problem whilst Transferring to New PC

PostMon Apr 19, 2021 2:16 pm

I am currently loading a new PC with Windows 10 and Hw 6.02 and getting a message about parsing that I do not understand. This error message occurs from a number of organs from different suppliers but not all.

[b]XML parsing error at line 1 (error occurred while parsing element) when processing the XML file Combs01.OrganCombination.OrganCombinationSet_Hauptwerk_xml.
Please request assistance form the supplier of the file.[/b]

I am currently transferring Hauptwerk from a 15-year-old windows 10 PC and Hw 6.02 to a new machine also Windows 10 and Hw 6.02. The new machine has two disc drives, 2 TB sata hard drive and a 2 Tb M.2 ssd. The source organ files are stored on the hard drive and directed to the ssd for installation. I do not understand what this message means and perhaps someone mat be able to tell what parsing is in the context Hauptwerk. It seems to me since a message of this type occurs on a number of different organs but not all that I have a local software/hardware/data problem.
I would be grateful if someone could explain the parsing and where I should start looking for a solution.
(Dr.) David G. Baldwin
Offline
User avatar

micdev

Site Admin

  • Posts: 2025
  • Joined: Sat Feb 09, 2008 9:24 am
  • Location: Canada, Quebec

Re: Parsing Problem whilst Transferring to New PC

PostMon Apr 19, 2021 4:43 pm

Greetings David,

Can you clarify what and how you are migrating your installation from Computer #1 (old) to #2 (new).
Can you clarify how computer #2' drives will be used (SSD and M.2)
When do you get those error messages?
How do you physically migrate from #1 to #2 the data (use of an external drive, thru a network?)

Here is how I would proceed to transfer from computer #1 to #2

You will need to make a Hauptwerk backup on computer #1 to save your settings
You will need to install Hauptwerk on #2 using "Custom installation" to indicate where some parts of Hauptwerk will be installed - yo will select which folders will be installed on your SSD or your M.2)

Then copy Hauptwerk' SampleSetsAndComponents folder (and its subfolders) to an external drive, then copy that folder (and its subfolders) from the external drive to computer #2 (in the right location selected when you installed Hauptwerk...).

Copy also the HW backup that you did to the external drive, then using Hauptwerk " File | Restore...", restore the backup on new computer.

Hope this helps

Not knowing your exact workflow, it is hard to say what is wrong, where those error messages are coming from.
Best regards
François

Virtually sharing my enthusiasm and experience with you
Worldwide technical assistance, consultation and ready to play system.

http://www.HauptwerkConsultant.com

AND Hauptwerk Support Manager
Offline
User avatar

David Baldwin

Member

  • Posts: 298
  • Joined: Sun Nov 12, 2006 12:08 pm
  • Location: Ross-on-Wye, Herefordshire, UK

Re: Parsing Problem whilst Transferring to New PC

PostTue Apr 20, 2021 2:57 am

The method i adopted was to install Hw on M.2 drive which is also my boot drive. The HD is used for storing things such as the original source files. I then installed the backup from #1. That completed, I then installed each organ from the source file. All files were transferred to #2 by rj45 crossover.
If the error occurs and it isn't on all organs, the message appears at the end of the installation where you clear all the extra information screens. There is one organ that brings up this error each time I try to load a sequencer selection. I display the current sequencer setting on a digital display. On this last organ there is some corruption on the display. I am wondering whether the backup file has become corrupted. Could I reload a previous backup instead?

I think this method that I have used is from a reply from either you or Martin when I was planning the move.
(Dr.) David G. Baldwin
Offline
User avatar

mdyde

Moderator

  • Posts: 13385
  • Joined: Fri Mar 14, 2003 1:19 pm
  • Location: UK

Re: Parsing Problem whilst Transferring to New PC

PostTue Apr 20, 2021 3:14 am

Hello David,

Some quick thoughts to add to Francois' reply:

For good measure, first check, via 'Help | About Hauptwerk' on your new computer, that you are indeed running v6.0.2 (since an older version might not be able to read files that were saved by a newer version). Assuming so:

The XML parsing errors that you're getting indicate that the relevant files have become corrupted somehow. That might be because of (for example):

- A faulty RAM board, either in the new PC (most likely), or on the previous PC from which the backup was made (resulting in the file having been corrupted before it was backed up). Test the PC's RAM thoroughly for errors. Also, if possible, see whether you get the same error when loading that organ on the original PC (so as to try to determine whether the file was corrupted on the original PC).
- A faulty SSD/hard-disk drive on one of the two PCs. (Test that too.)
- (Unlikely) some other hardware fault on one of the two PCs, e.g. the power supply.
- The files having become corrupted somehow as you transferred them between the two PCs.

David Baldwin wrote:I think this method that I have used is from a reply from either you or Martin when I was planning the move.


Maybe that was this topic: viewtopic.php?f=4&t=19662&p=147454#p147447

(I'll leave you to work with Francois if needed.)
Best regards, Martin.
Hauptwerk software designer/developer, Milan Digital Audio.
Offline
User avatar

engrssc

Member

  • Posts: 7100
  • Joined: Mon Aug 22, 2005 10:12 pm
  • Location: Roscoe, IL, USA

Re: Parsing Problem whilst Transferring to New PC

PostTue Apr 20, 2021 4:28 am

mdyde wrote:A faulty RAM board, either in the new PC (most likely), or on the previous PC from which the backup was made (resulting in the file having been corrupted before it was backed up). Test the PC's RAM thoroughly for errors. Also, if possible, see whether you get the same error when loading that organ on the original PC (so as to try to determine whether the file was corrupted on the original PC).

The best RAM testing software is MemTest86.

https://www.memtest86.com/index.html

Follow the instructions (scroll down to the video) to create a bootable UEFI flash drive. Use the Free Version.

https://www.memtest86.com/download.htm

Technical details:

https://www.memtest86.com/technical.htm

Rgds,
Ed
Offline
User avatar

IainStinson

Member

  • Posts: 1172
  • Joined: Tue Dec 29, 2009 6:08 pm
  • Location: NW England, UK

Re: Parsing Problem whilst Transferring to New PC

PostTue Apr 20, 2021 9:00 am

David,
I assume these errors occur when you are using one of the organs on new machine.

Are you running the same versions of the organ on the new machine as you were on the old machine? I seem to remember that on a few occasions sample set makers have made changes between versions of their organs which made combination settings incompatible between versions of their organs; this might cause the problem.

What software are you using to carry out the copy from the old machine to the new one?

I used an external drive when I copied the data from the old to the new machine, which gave a useful back up as well.

You could use a utility to compute the MD5 checksum on both machines of one of the failing combination files and check k it is the same on both systems? This would indicate if the files were different.

Good luck.

Iain
Offline
User avatar

micdev

Site Admin

  • Posts: 2025
  • Joined: Sat Feb 09, 2008 9:24 am
  • Location: Canada, Quebec

Re: Parsing Problem whilst Transferring to New PC

PostTue Apr 20, 2021 11:40 am

Hell David,

If the error occurs and it isn't on all organs...


Can you tell me for which organ(s) you get the error. No error when loading on the old computer? Have you tried to re-download the installation packages? Look like some corrupted files.
Best regards
François

Virtually sharing my enthusiasm and experience with you
Worldwide technical assistance, consultation and ready to play system.

http://www.HauptwerkConsultant.com

AND Hauptwerk Support Manager
Offline
User avatar

David Baldwin

Member

  • Posts: 298
  • Joined: Sun Nov 12, 2006 12:08 pm
  • Location: Ross-on-Wye, Herefordshire, UK

Re: Parsing Problem whilst Transferring to New PC

PostTue Apr 20, 2021 3:53 pm

I did wonder whether the backup was corrupted because of some different characters appearing in the display. I decided to reload a second backup. (I did two before starting the transfer.) Today I have reinstalled each organ and have not had a single parsing error. That suggests that the problem has gone?
Thanks for all your help.
(Dr.) David G. Baldwin

Return to Technical support

Who is online

Users browsing this forum: No registered users and 3 guests