Page 1 of 1

Strange behaviour Fresh installed HW 6

PostPosted: Fri Jun 18, 2021 9:17 pm
by lemmeling
Hello everyone,

Quick question.
I purshased myself a laptop and installed the latest HW 6 version on it.
I directly installed the 6.02 from scratch, so I did not first install the 6.01 and then upgraded...
As with my main console I finished the first-time run wizard and then clicked cancel to avoid that St Anne is being loaded.
I never use that organ, so I don't want an extra cache-file to be created. I always do that with fresh HW installs, never caused any problems.
I also do that if I reinstall HW on my main console.

After that I installed a HW sampleset, in this case the Mierke...
However, each time I close HW and relaunch it, it's rebuilding some temporairy files from the St Anne set.
So instead that HW directly runs the Mierke (I set hauptwerk to start with the sampleset on favorite 1) it always first starts doing.... something, like re-(installing) certain parts of the St Anne set.
I tried deleting HW 6 completely, re-installing it, nothing helps... Never had that problem on my console....
I tried loading the St Anne completely (so making a cahce). Didn't help either.
Any ideas as what is causing this and how to resolve it?

My configuration on the laptop emulates a bit the one on my main console.
On the console I have 2 seperate SSDs, the first for windows, the second (D) for Hauptwerk, except for the VST plugin.
On my laptop I do not have two seperate disks, so I emulated two "disks" by partitioning my disk in C and D with Hauptwerk being installed on the D (except of course again for the plugin).
On both laptop and main console I use the latest Win 10 build, 2105.

@ Martin, I made a diagnostic file, but I'm awaiting your approval before sending it.

Thanks everyone, have a nice evening (night :-) )

Laurens
Belgium

Re: Strange behaviour Fresh installed HW 6

PostPosted: Fri Jun 18, 2021 9:29 pm
by mnailor
Did you try a fresh install and not canceling the load of St Annes the first time? You can uncache it later if you get a successful installation by letting it finish what it wants to finish. Maybe you canceled installing St Annes components instead of a cache load?

To uncache, use Organ / Load organ, adjusting..., OK, wait a few seconds for it to delete the cached version and then Cancdl.

Re: Strange behaviour Fresh installed HW 6

PostPosted: Fri Jun 18, 2021 10:34 pm
by lemmeling
Hello,
Thanks for your reply.
No, unfortunately this didn't help either...
Thx anyways,

Laurens

Re: Strange behaviour Fresh installed HW 6

PostPosted: Sat Jun 19, 2021 12:22 am
by lemmeling
Hi everyone,

I think I found the solution and the reason (?) ....
I tried to install Hauptwerk only to the C partition, the same where my Windows is installed on.
That worked perfectly.
So then I figured, it must be something with the partition and/or filesystem (NTFS of course) of the D, so then I deleted the partition D with Windows Disk Management and re-made it after that.
I re-installed Hauptwerk again on the D.... worked like a charm.
In short, I think somehow my D-partition was corrupted.

Cheers,

Laurens

Re: Strange behaviour Fresh installed HW 6

PostPosted: Sat Jun 19, 2021 2:50 am
by mdyde
Hello Laurens,

During Hauptwerk installation, the Hauptwerk installer copies the installation package for St. Anne's into Hauptwerk's HauptwerkSampleSetsAndComponents folder tree. Then when you (first) launch Hauptwerk, Hauptwerk's component installer will install that St. Anne's package automatically (for which there is intentionally no means by which it can be cancelled, since the package needs to be present even if you don't actually use St. Anne's), then Hauptwerk will try to delete that installation package. It doesn't matter whether you cancel loading St. Anne's when prompted.

If the St. Anne's package tried to re-install again when you next/subsequently launched St. Anne's then it means that you had some file/folder permissions issues that were preventing Hauptwerk from being able to delete that file after installing it. (For example, having run the Hauptwerk installer using a different Windows account from which you ran Hauptwerk might give that problem, or perhaps you had some incorrect permissions on your D: drive that were preventing the Windows account from which you ran Hauptwerk from deleting files on it.)

Anyway, glad to hear you have it working now.