Page 1 of 1

HW installer stuck

PostPosted: Fri Jun 24, 2022 3:07 am
by JulianMoney-Kyrle
I am in the process of migrating my HW 7 installation to an external SSD as I am running out of disk space and for some reason my motherboard seems to be incompatible with the PCIe NVMe SSD's that I have tried with it. I am using an 8TB Sabrent drive in a Sabrent housing which seems to be machined out of a solid block of aluminium to act as a heat sink. I am running Windows 10.

My first attempt a few weeks ago failed as the external drive disappeared from Windows part-way through the installation. The housing had become very hot (I would estimated about 70 degrees) and I think it fried the electronics in the interface, as the disk worked fine afterwards in a different computer.

My second attempt was yesterday, using an upgraded Sabrent housing which looked as if it had better thermal properties (it has ridges to increase the surface area and it is black); for good measure I placed it on an inverted heavy steel saucepan with a very flat aluminium base. I have a lot less data to move this time, as I have had to reinstall HW and some of my sample sets from scratch meanwhile in order to use the organ at all. I decided to do it in two stages, moving everything except the HW cache first time around.

The first stage worked fine. The HW installer took around 4 hours to move the data to the external drive, which became hot, but the housing felt like about 55 degrees to the touch. Afterwards HW loaded and ran fine, and my settings were preserved (I have backed them up manually just in case). So I started the second stage, which was migrating the cache, and left it running overnight. Although the installer didn't appear to be doing anything, the cache files were steadily appearing in on the external disk in Windows Explorer and the Task Manager showed the expected disk activity.

This morning the installation process appears to have stopped. There is a dialog box with the message:

Insert New Media
Incorrect Media Volume : (path to the HW installer)
Please insert Disk1 or Select 'Browse...' to locate it manually

Selecting Browse and navigating to the HW installer brings up the same dialog box.

The HW installer screen has everything ticked as far as Pre-installation Summary, and there is an arrow against Installing.

Under the HW logo there is the message:
Installing... CheckAndFixFilePermissions.bat

The progress bar shows 4%

I am using the same installation files that I used yesterday (and for my previous successful HW installation).

The only other odd thing is that Microsoft Edge was running when I came down. Sometimes insects crawling across my touchscreen monitor can activate buttons on the Taskbar, and I think that is probably what happened.

I am reluctant to do anything that might halt the installation altogether, and leave me with the task of installing all my sample sets once again from scratch (though at least I won't have to set them all up as I have the HW backup).

Ideas anyone?

Re: HW installer stuck

PostPosted: Fri Jun 24, 2022 9:04 am
by mnailor
Can you still copy your cache directory with Windows copy and paste, then delete the old cache? You can move the files yourself before running the installer to change the location.

Re: HW installer stuck

PostPosted: Fri Jun 24, 2022 9:56 am
by micdev
Hello Julian,

Cache file folder can be very large. The error message seems to indicate that Windows lost the connection with the drive (either the source or destination) and is trying to resume the copy.

Mnailor is right, you could copy/paste the cache folder from your source drive to the external device. You may want, instead of copying the whole folder at once, copy 3-4 files at a time. It seems that your devices are overheating. By copying by smaller chunks your drive will be able to cooldown between 2 copies.

Once the files copied, delete them from the source folder then run the installer to change the cache folder' location.

If you still have problem, you could simply erase the cache folder, run the installer to change the location (no file will be copied since there are none) then you will need to re-cache your organs one at a time.

Re: HW installer stuck

PostPosted: Fri Jun 24, 2022 12:19 pm
by JulianMoney-Kyrle
The HW installer has already moved the cache folder across, and deleted it from its original location (I think it checks that the copy is intact before deleting the original). The only thing remaining at the original location is a temporary folder which is empty (I have checked for hidden files).

The new drive is still accessible to Windows; I think it it had disconnected at any point during the installation process there would be a specific error message to this effect. So really I am at a loss to know what the Hauptwerk installer is looking for when it is asking me to insert Disk1.

I suppose I could use the Windows Task Manager to shut down the installer and see if the installation has reached the point where HW actually runs - I am a bit reluctant to do this without knowing whether there are any configuration files that it needs to sign off first, however, such as telling HW the location of the cache.

Re: HW installer stuck

PostPosted: Fri Jun 24, 2022 1:13 pm
by micdev
If the cache folder was moved, then you need to check if Hauptwerk configuration file was modified.

Simply start Hauptwerk then
- Click Help | View activity log
- Since you will be positioned at the end of the log file, scroll up until you see
2022-06-22-XX-XX-XX: INF:4165 Welcome to Hauptwerk. (where xx is the time)
- Now look at the lines below (around the 25th) where you will see one starting by
Hauptwerk temporary files folder:... You will see the location of your folder.

If it is the right location, then all should be fine, but if it is still the original location (old location), then run again the installer and change the TEMPORARY folder location to the new location.

Re: HW installer stuck

PostPosted: Fri Jun 24, 2022 6:01 pm
by JulianMoney-Kyrle
Thank-you, Francois, that was very helpful.

I exited the installer, and found the log file, which was in HTML so I was able to read it without trying to open what may have been an incomplete installation of HW. The path to the temporary folder referred to the old drive, so I ran the installer again. It completed without any problems, and HW is now running, with my settings intact.

Unsurprisingly, the organs seem slower to load from the external drive than previously from the internal one, but so far I don't think it is as slow as I feared it might be; I don't know what the limits are when connecting an NVMe drive through a USB3 port compared to direct access from the motherboard.

Anyway, it seems that I have a working organ again, so although I haven't been able to practise today, I hope to be able to prepare for my lesson next week.